So I just got a new dell with the Intel 5300 wireless card, and I'm booting from the BT4 live dvd. My issue is (I think) that it appears packet injection isn't working, or stops working. I'm not all that new to Linux, though I'm a little rusty, and I've only been using backtrack for a few days, so I'll step through what I'm doing. If any more info would help, let me know.

First, I run
airmon-ng start wlan0 09
I know my wireless card is wlan0 and my AP is on channel 9.

airodump-ng --output-format ivs --ivs --channel 9 --bssid [bssid] -w wireless mon0
And this appears to work fine. Beacons rise steadily, PWR is usually around -30 or -40, and there is typically 1-4 stations listed.

Here is where the problem is. If i run
aireplay-ng -9 mon0
It will tell me "Injection is working!" and get 29 or 30/30 directed probe requests.

Now i can run an ARP request attack (aireplay-ng -3), and it will steadily increase packets read, ARP req's will go up every few seconds, but i never get any ACKs. A -9 test will still do the same thing. If i run a fragement attack, it will just keep asking me every minute or two if i want to use this packet, and nothign useful ever happens.

If I try a fake auth attack, everything generally goes to hell. Airmon will stop collecting data packets (but not beacons), a -9 test will fail, and the fake auth might get a packet or two with success, but then will stop working pretty much forever. If i stop mon0 and restart it, I can also start over, but it happens every time.

I've tried faking my MAC address as a computer thats already authenticated to my network, but that doesnt seem to change anything. Does anyone have any ideas whats wrong? I've read the 5300 doesn't work all that well with injection- but I was under the understand it DOES work. Am I mistaken?