Results 1 to 3 of 3

Thread: Injection doesnt work/stops working/works intermittantly - Intel 5300

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Sep 2009

    Default Injection doesnt work/stops working/works intermittantly - Intel 5300

    So I just got a new dell with the Intel 5300 wireless card, and I'm booting from the BT4 live dvd. My issue is (I think) that it appears packet injection isn't working, or stops working. I'm not all that new to Linux, though I'm a little rusty, and I've only been using backtrack for a few days, so I'll step through what I'm doing. If any more info would help, let me know.

    First, I run
    airmon-ng start wlan0 09
    I know my wireless card is wlan0 and my AP is on channel 9.

    airodump-ng --output-format ivs --ivs --channel 9 --bssid [bssid] -w wireless mon0
    And this appears to work fine. Beacons rise steadily, PWR is usually around -30 or -40, and there is typically 1-4 stations listed.

    Here is where the problem is. If i run
    aireplay-ng -9 mon0
    It will tell me "Injection is working!" and get 29 or 30/30 directed probe requests.

    Now i can run an ARP request attack (aireplay-ng -3), and it will steadily increase packets read, ARP req's will go up every few seconds, but i never get any ACKs. A -9 test will still do the same thing. If i run a fragement attack, it will just keep asking me every minute or two if i want to use this packet, and nothign useful ever happens.

    If I try a fake auth attack, everything generally goes to hell. Airmon will stop collecting data packets (but not beacons), a -9 test will fail, and the fake auth might get a packet or two with success, but then will stop working pretty much forever. If i stop mon0 and restart it, I can also start over, but it happens every time.

    I've tried faking my MAC address as a computer thats already authenticated to my network, but that doesnt seem to change anything. Does anyone have any ideas whats wrong? I've read the 5300 doesn't work all that well with injection- but I was under the understand it DOES work. Am I mistaken?

  2. #2
    Just burned his ISO
    Join Date
    Nov 2009


    I seem to have a similar problem, using an Intel 5300 AGN card. I wonder if you ever found a solution to your problem.
    I can monitor without any problems, aireplay -9 even says injection works when trying broadcast probes, but targeted probes do not work (actually one goes through, then the rest don't). As soon as I try aireplay-ng -3 it seems to generate a problem. Basically aireplay-ng -1 works, as many times as I try it, and after aireplay-ng -3 starts, I can capture a few ARP packets,but after sending packets, I get no ACKs at all. If I then stop and try aireplay-ng -1 again, I never can associate again, it no longer seems to work. I have to stop monitor/injection mode and restart it to be able to have aireplay-ng -1 start working again.Really weird.
    If you or anyone else has an idea why this is happening, I would really be grateful,

  3. #3
    Just burned his ISO
    Join Date
    Jan 2010

    Default Packet injection in 5300

    same case here...some one please try and help us ..thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts