Results 1 to 5 of 5

Thread: cups problem

  1. #1
    Junior Member loop4me's Avatar
    Join Date
    Mar 2008

    Default cups problem

    I attach my hp1020 on bt4-pre box, install foo2zjs and then i noticed this problem with cups. When i /etc/init.d/cups start i got

    Starting Common Unix Printing System: cupsdcupsd: Child exited with status 1!

    Same thing when start cupsd.
    This is the syslog line.

    cupsd: Unable to read configuration file '/etc/cups/cupsd.conf' - exiting!

    Permissions are ok on cupsd.conf. I tried to reinstall cups, foo2zjs and printconf,hp-setup.
    Any ideas?

  2. #2
    Junior Member loop4me's Avatar
    Join Date
    Mar 2008


    I figure it out!

    What i did is , i put LogLevel in cupsd.conf in debug mode.

    LogLevel debug #warning is default

    Then, cat /var/log/cups/error_log
    and the interesting line was

    "/etc/cups/ssl/server.crt" is a bad symlink - No
    such file or directory

    symlink is...

    lrwxrwxrwx 1 root root 36 2009-07-07 16:54 server.crt -> /etc/ssl/certs/ssl-cert-snakeoil.pem

    ...but the /etc/ssl/certs/ssl-cert-snakeoil.pem was missing
    Acctuly i didn'n know i have to generate one for this purpose.
    So i,
    apt-get install --reinstall ssl-cert

    #Think that make-ssl-cert generate-default-snakeoil can do the trick.

    I rerun hp-setup. And the test pages was printed.
    The /etc/init.d/cups start finaly worked!

    Ok, i had to set defaulty printer,
    lpstat -a
    lpoptions -d <PRINTER>

    And it's working.

    However, there is a little problem, the default printer is set ,no problems printing from shell and the firefox, but seems that kpdf, kate and other kde programs don't recognized the printer.

    There is a .lpoptions in the ~/ directory but it seems that kde is not reading configuraon from it.
    I, cat /etc/cups/lpoptions >> ~/.lpoptions and restart kde but no good. Steel showing me in kde programs same three print devices (print to file (PDF) ,print to file (Post Script), Sent to Fax).
    I rm ~/.lpoptions and restart kde, and same thing (except the ~/.lpotions is missing ,kde didin't create new one)

    So is ~/.lpoptions file from which kde get what printer devices to use?

  3. #3
    Just burned his ISO imported_h4x0r's Avatar
    Join Date
    Mar 2006


    apt-get install --reinstall ssl-cert

    solved my printingproblem too.

  4. #4
    Junior Member loop4me's Avatar
    Join Date
    Mar 2008


    I am glad to hear that h4x0r.

  5. #5
    Junior Member najib's Avatar
    Join Date
    Jul 2008

    Wink apt-get install --reinstall ssl-cert

    It solve my problem too.

    apt-get install --reinstall ssl-cert
    apt-get autoremove
    /etc/init.d/cups start

    Thank to loop4me


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts