Alright, here's where I sit with this.

I'm running the BT4PR installed on my drive. I'm logging in as root, so theres no need for any sudoing.

First off... my wireless shows as eth1. I dont know if this is an issue or not.

When I run airmon-ng in Konsole, I get the following:

Interface Chipset Driver
eth1 Unknown wl

when I run airmon-ng start eth0, it gives me the same output.

When I run airodump-ng eth1, I get the following:

ioctl(SIOCSIWMODE) failed: Invalid argument
and then it basically says ARP linktype is set to 1 (ethernet)

if I run ifconfig it shows eth0 (my ethernet) and eth1 (my wireless)

iwconfig yields lo and eth0 have no wireless configs but eth1 does.

So Heres where I start trying to patch and change stuff.
The best looking tutorial I have found is as such:

I have downloaded everything mentioned, all correct versions.

everything is done in /usr/src

tar xjf compat-wireless-2.6.tar.bz2
cd compat-wireless-2009-08-31
patch -p1 < mac80211_2.6.28-rc4-wl_frag+ack_v3.patch
This is where I get my first problem. output reads:

patching fil net/mac/80211/tx.c
Hunk#1 FAILED at 611
1 out of 1 hunk FAILED -- saving rejects to file net/mac80211/tx.c.rej

I continue anyway, just out of spite.

patch -p1 < mac80211-2.6.29-fix-tx-ctl-no-ack-retry-count.patch
make -j4
make unload
Biggest problem starts here. Output:

Unloading lib80211_crypt_tkip...
Unloading lib80211...
FATAL: Module lib80211 is in use.
make: *** [unload] Error 1

I pretty much give up here. rest of instructions are as follows.

make install
echo options iwlagn swcrypto=1 >> /etc/modprobe.d/options
make load

Another strange thing is that even if I go to Konsole and use "service networking stop", Im still able to see all my devices using ifconfig and iwconfig. I've even stopped it through Services > Network > Network stop.

Any ideas here? I would really like to get BackTrack 4 running right, since everything I've read in the forums says the 4965agn works out of the box. Just very frustrated, I've been at this for about a week.

Anyone out there? Just looking for some tips here...