so after trying to manually format / partition / restore my flash drive from a Win 7.iso mounted while running Windows OS... as seen here:

Install Windows 7 From USB Drive/Pen Drive

(hopefully links r ok here)

After doing this, my flash drive became unreadable by almost every OS and formatting client. I have tried manually setting permissions and partitioning using linux and Windows... Fail... tried every forumed answer... i also tried using Disk Utility in mac (never failed for me)... it includes the MasterBootRecord within partition settings and FAT...

My question is, lets pretend I just messed up the primary partition, is there a "GOD" command to allow me to format/partition this thing back to normal? Some methods give me an error of permission, is there a chmod of the sort designed for drives that cant mount?

heres a snapshot of my backtrack fail of format:

GParted 0.3.8

Libparted 1.8.9

Format /dev/sdb1 as ntfs 00:01:52 ( ERROR )

calibrate /dev/sdb1 00:00:00 ( SUCCESS )

path: /dev/sdb1
start: 128
end: 7905151
size: 7905024 (3.77 GiB)
set partitiontype on /dev/sdb1 00:00:00 ( ERROR )
libparted messages ( INFO )

Error opening /dev/sdb: No such file or directory