This appears to be an issue of a certain usb controller (in a Thinkpad A22m 2628-RSU) not playing well with certain usb memory keys (Imation Clip 2GB).

Question 1: Bug? Seems to happen only with this model of usb stick on this model of laptop.

Question 2: Workaround? e.g. How in backtrack do you disable usb 2.0 speeds and connect at something slower? The usual google advice seems to be modprobe -r ehci_hcd or rmmod ehci_hcd but that module doesn't appear to be in use in backtrack? This hardware level stuff isn't really my forte, so I could use some insights.

So I've tried this on a pair of relatively ancient Thinkpad A22m model/type 2628-RSU laptops that are both having some issues in Backtrack4 dealing with a certain model of USB memory keys. In particular, I have 2 identical 2GB Imation Clip usb memory keys that seem to give it fits. These same keys in a newer IBM desktop or Lenovo thinkpads with backtrack: never a problem. I've tried a few different model keys in the problem A22m ancient laptop with backtrack also with no problem. There's something magically awful about the A22m and the Imation Clip 2GB.

When I plug the USB key in after backtrack is up, the console fills with the message:

hub 1-0:1.0: unable to enumerate USB device on port 1
appears continuously for quite a while (around 16 minutes! 2286 lines of the above msg in dmesg which was amazingly the same number of messgages over 2 tests with 2 different keys) until--if you're lucky--finally you get

usb 1-1: new full speed USB device using uhci_hcd and address 50
usb 1-1: configuration #1 chosen from 1 choice
Possibly relevant bits from lsusb -v -s 1:50 are :

Bus 001 Device 050: ID 0718:0492 Imation Corp.
bcdUSB 2.00
bMaxPacketSize0 64 
idVendor 0x0718 Imation Corp
idProduct 0x0492
iManufacturer 1 Imation
iProduct 2 Clip
Those results above were identical on both of the Imation Clip 2GB's I tried -- except 2nd one I tried came up on Bus 001 Device 004.

lsusb on the root hub lsusb -v -s 1:1 has these highlights:

Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
bLength 18
bDescriptorType 1
bcdUSB 1.10
bDeviceClass 9 Hub
bDeviceSubClass 0 Unused
bDeviceProtocol 0 Full speed (or root) hub
bMaxPacketSize0 64
idVendor 0x1d6b Linux Foundation
idProduct 0x0001 1.1 root hub
bcdDevice 2.06
iManufacturer 3 Linux uhci_hcd
iProduct 2 UHCI Host Controller
wHubCharacteristic 0x000a
 No power switching (usb 1.0)
 Per-port overcurrent protection
bPwrOn2PwrGood 1* 2 milli seconds
Thanks for any help or workarounds!