Objective: Run BackTrack 4 off my USB Thumb Drive.

Problem: No BIOS support to boot from USB.

- Dell Dimension 4500 Series, with BIOS version A04
- using an 8GB USB drive, installed with BackTrack 4 configured with disk encryption

Steps taken so far:
- carefully followed the beautifully written HowTo "Install BackTrack Persistent to USB with full disk encryption": confirmed successful operation of the install by running on another machine with proper BIOS support
- cofirmed BIOS boot order (floppy, CD/DVD, HD), all enabled
- checked for BIOS update: confirmed running the latest available
- googled the issue until my fingers bled: no luck

More details on particul tries:
1) Tried the tutorial "How to Create a Boot CD to Boot a Ubuntu 9.04 Live USB", available at the pendrivelinux site Make a USB Boot CD for Ubuntu 9.04 | USB Pen Drive Linux.
- didn't work, which in hindsight is obvious since the file structure is different in the BackTrack blend of Ubuntu. This might work with a few tweaks but I don't know which particular files to grab/reference from a BackTrack 4 install DVD (?)

2) added things like "nocd" and "cdrom-detect/try-usb=true " to the boot settings when loading from a confirmed-working BackTrack 4 install DVD. These didn't work but maybe there are magic params that will (?)

3) per steps outlined in previously referenced HowTo "Install BackTrack Persistent to USB with full disk encryption", tried booting from DVD then making the USB install active (mkdir /mnt/backtrack4, mount /dev/mapper/vg-root /mnt/backtrack4, etc). This didn't work either but maybe there are magic commands that would make it work (?)

Comments appreciated. Thanks.