Results 1 to 3 of 3

Thread: Aireplay-ng doesn't inject on Intel Wifi 5100?

  1. #1
    Just burned his ISO
    Join Date
    Aug 2009

    Default Aireplay-ng doesn't inject on Intel Wifi 5100?

    Aireplay-ng doesn't inject with my Intel Wifi 5100. When i type in aireplay-ng -3 -b 00:11:22:33:44:55 -h 11:22:33:44:55:66 -x 50 wlan0, I get: read 170205 packets (got 0 ARPs and 0 ACKs) sent 0 packets. I have already started airdump-ng but I have not associated with an AP.

    Is aireplay-ng not working because I have not associated to an AP (intel 5100 does not support associating but needs wpa_supplicant and i have no idea what it is) or is it because of my drivers? My driver is iwlagn, chipset: unknown.

    If i need to associate first, can someone guide me to a noob guide for wpa_supplicant? I found a few on the net but i'm confused

  2. #2
    Just burned his ISO
    Join Date
    Mar 2009


    ingection using AGN 4965, AGN 5100, AGN 5300 etc. is not yet supported. Well it is possible but near imposible. i have a 4965 in my laptop and it dosent work so i bought a differnt wireless card on ebay ( Alfa awus036H) and it works like a charm. I highly recomend it. I got it on ebay with a 9 dbi gain antenna for 45 bucks.

  3. #3
    Just burned his ISO
    Join Date
    Aug 2009


    From what I understand, you have to be associated with the AP in order to inject. If you aren't then the AP will simply discard your (injected) packets...and that means that you aren't generating any traffic.

    Association for WEP (haven't tried anything with WPA yet) can be accomplished if one uses a fake authentication option in aireplay-ng. You can look up the syntax on your own.

    Authentication shouldn't fail for you if you're trying to get at your own AP, since you shouldn't be restricting MAC addresses if nothing has worked previously.

    In any case, I'm currently working on my own lovely WRT54G with an Intel 5100 AGN and authentication (and injection) goes fine. I'm not sure what can be done to get an ARP if the network doesn't have any clients attached, so I just let another machine of mine connect and then spammed it with deauths.

    Oh, and there's another thing. For some or other reason when I do an airmon-ng start wlan0, it creates another interface (mon0, mon1, etc) which is in monitor mode. Doing anything with wlan0 (like an injection test) fails. I wonder why...

    That might be your problem...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts