Results 1 to 2 of 2

Thread: Metasploit plugin issue

  1. #1

    Default Metasploit plugin issue

    Well I guess I'm confined to the shallow end of the pool for the first 3 days, thanks guys. Hopefully someone knowledgeable is surfing here and catches this post cuz I'm my issue is somewhat urgent.

    So, on to the problem. I'm trying to write a plugin for the metasploit framework. Very long story short, it's not working no matter what I do. As a test, I tried to load the sample plugin through the Msf CLI, and surprise surpirse, I get the same error.

    Sample.rb is a test plugin that is shipped with MSF. As I understand it you should be able to pop open the Msf CLI and do a 'load sample.rb' and the plugin should load. Yet, even with this default test plugin, all I get is an error saying:

    [-] Error while running command load: No classes were loaded from /path/to/framework-3.2/plugins/sample.rb in the Msf::Plugin namespace.

    Tested on both linux and windows, same result. Anybody else have this issue? This was tested on each box with a fresh install of the latest and updated version of the framework.

    More important than if anyone has the same problem, does anyone know what causes it or how to fix it? I can't get back to testing my plugin until I know at least the default plugins work properly.

  2. #2
    Very good friend of the forum Gitsnik's Avatar
    Join Date
    Jan 2010
    The Crystal Wind


    I'd say you've got an awry sample file to work from (check the first 3 uncommented non blank lines especially). HDM has some nice tutes up on his site regarding adding more, which I trust you've looked into - follow the samples he works with there.
    Still not underestimating the power...

    There is no such thing as bad information - There is truth in the data, so you sift it all, even the crap stuff.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts