Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Intel Wifi link 5100 (Lenovo X200T)

  1. #11
    Just burned his ISO
    Join Date
    Oct 2009


    I've been having the same problems with this card in combination with an out-of-the-box install of backtrack 4. Aireplay -9 (test mode) even states that injection is working (I'm not exactly sure at which step in the process the actual injection function is used/needed, but Ive come to seriously doubt that it works). But after finding a fragmented packet to use with Aireplay -5 (fragment attack) it wont receive/find/get any packets it needs to make the 1500byte key stream.

    I've tried using my other machine with a different card (Linksys PCI), and it worked like a charm (exact same access point and attack type).

    I noticed that the windows version of Aireplay needs a special driver from Wildpackets ( hxxp://www [dot] wildpackets [dot] com/support/downloads/drivers ). Their info page states:
    "Intel Centrino
    OmniPeek natively supports WLAN adapters that utilize the Centrino 3945 chipset for a/b/g wireless analysis. A custom driver is not needed for these adapters as the application will automatically recognize the adapter. At the present time, the 3945 chipset is only supported on the Windows XP platform. Other Intel chipsets such as the 4965 and 5100 cannot be supported by OmniPeek until Intel adds ISV promiscuous mode to their feature set. It is incumbent upon Intel to make these changes, as OmniPeek already has the ability to recognize and work with chipsets that have this capability."

    It seems that Intel hasn't implemented everything that's needed for this software to work (at least on XP). My expertise isn't nearly enough to be sure, but it would seem to be logical that linux drivers could have similar problems with this type of chipset.

    If anyone out there has the expertise or experience to comment in any way, it would be much appreciated. This card is driving me crazy!


  2. #12
    Just burned his ISO
    Join Date
    Nov 2009


    Same here. Got an 5100 agn - didnt work out of the box. -9 says, it should work, if I use the command -9 mon0 -i wlan0 the last two tests fail.

    AP: FritzBox 7050.

    Monitor mode works, FakeAuth works.

    I installed BT4 on a USB-HDD an replaced (booting with live CD again an just copied) the three .c-files in the directory.

    -- Nothing changed... Are there more steps to do? Compile sth.?
    I knew much about Computers but I'm not very familiar to Linux at all.

    Please help - I made a bet with my brother in law to a case of beer, that I get his WEP-Key.

  3. #13
    Just burned his ISO
    Join Date
    Oct 2009


    Well i finally solved my problems with the Intel 5100.
    I bought an external usb wifi card
    Some are really awesome. Especially range/reception wise..

  4. #14
    Just burned his ISO
    Join Date
    Dec 2009

    Default iwl 5100 agn aireplay-ng injection attacks

    Sorry in advance if this information is already up in another thread but this seemed like the most appropriate place to post my reply.

    I am a bit of a noob to linux but here is what I've found about the 5100 agn.

    The iwl 5100 agn does support injection but only aireplay-ng -0 and -1 attacks. Read on for more detailed info!

    If you have 2 wireless adapter you can test the injection capabilities of both of them. Using the iwlagn driver packaged with BT 4 Pre-Final I get these results when running the aireplay-ng -9 test:
    5100 agn injection test results:

    aireplay-ng -9 -i mon1 mon0

    14:15:49 Trying broadcast probe requests...
    14:15:49 Injection is working!
    14:15:51 Found 3 APs

    14:15:51 Trying directed probe requests...
    14:15:51 00:00:00:00:00:00 - channel: 1 - ''
    14:15:57 0/30: 0%

    14:15:57 00:1C:F0:68:B1:6E - channel: 1 - '*****'
    14:15:57 Ping (min/avg/max): 1.206ms/8.948ms/23.202ms Power: -21.97
    14:15:57 30/30: 100%

    14:15:57 00:19:5B:60:38:F1 - channel: 1 - '*****'
    14:15:58 Ping (min/avg/max): 2.945ms/15.914ms/39.838ms Power: -54.93
    14:15:58 30/30: 100%

    14:15:58 Trying card-to-card injection...
    14:15:58 Attack -0: OK
    14:15:58 Attack -1 (open): OK
    14:15:58 Attack -1 (psk): OK
    14:16:02 Attack -2/-3/-4/-6: Failed
    14:16:06 Attack -5/-7: Failed
    In these test results you can see that the 5100 does support aireplay injection attack -0 (deauth) and -1 (fakeauth) open and psk. While it fails the other attacks such as interactive, arpreplay, chopchop, fragment, etc.
    So this means the initial result to the basic test....

    14:15:49 Trying broadcast probe requests...
    14:15:49 Injection is working!
    14:15:51 Found 3 APs

    ...Is both is true but not for all of the attacks aireplay-ng is capable of.

    I have verified these test result myself by testing each attack extensively on a dlink dir-655 my own of coarse.

    I also ran the same test but testing my atheros chipset pcmcia card using the ath5k driver and recieved these results.
    ath5k results:

    aireplay-ng -9 -i mon0 mon1

    14:19:43 Trying broadcast probe requests...
    14:19:43 Injection is working!
    14:19:44 Found 4 APs

    14:19:44 Trying directed probe requests...
    14:19:44 00:1C:F0:68:B1:6E - channel: 1 - '*****'
    14:19:45 Ping (min/avg/max): 1.013ms/5.643ms/12.200ms Power: -6.00
    14:19:45 30/30: 100%

    14:19:45 00:19:5B:60:38:F1 - channel: 1 - '*****'
    14:19:45 Ping (min/avg/max): 1.875ms/9.921ms/81.112ms Power: -41.57
    14:19:45 30/30: 100%

    14:19:57 Trying card-to-card injection...
    14:19:57 Attack -0: OK
    14:19:57 Attack -1 (open): OK
    14:19:57 Attack -1 (psk): OK
    14:19:57 Attack -2/-3/-4/-6: OK
    14:20:01 Attack -5/-7: Failed
    These result show that this card supports all aireplay-ng attacks except -5 (fragment) and -7 (clientfrag). I have also confired these results with my own testing, again on my own dir-655.

    So this leads me to the question has anyone out there found a patch or fix to enable all aireplay-mg attacks for the 5100 using kernel Also has anyone purchased a usb, cardbus or expresscard that has good reception and that they have tested and confirmed works with all aireplay-ng attacks? I have checked the compatible cards and drivers at and found that they list the 5100 as supporting injection which I think confuses people and doesn't give the full lowdown on what attacks they support.

    Hope this helps clear up some questions about the iwl 5100 agn and I hope someone has a good suggestion on an adapter.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts