Results 1 to 3 of 3

Thread: Getting wifi to work?

  1. #1

    Question MadWifi driver on Atheros card not working


    I have been trying for the past two weeks to solve this problem but no success as i am completely new to linux slackware. I have a gateway netbook running backtrack 3 usb, (about to install backtrack 4) but i cannot get the wifi working. It is an atheros ar5b95 wifi card that should be compatible with the Madwifi driver. I have tried both compiling my own source and installing a pre made package. I followed the tutorial on hxxp://

    And tried to follow Exploitz's tutorial, but no success.

    bt Desktop # cd madwifi-0.9.4
    bt madwifi-0.9.4 # ls**  ath_rate/  hal/      kernelversion.c*  readme*      scripts/
    COPYRIGHT*      ath/           contrib/   include/  net80211/         regression/  thanks*
    Makefile*       ath_hal/       docs/      install*  patches/          release.h*   tools/
    bt madwifi-0.9.4 # sudo make
    Checking requirements... ok.
    Checking kernel configuration... ok.
    gcc -o athdebug -g -O2 -Wall -I. -I../hal -I..  athdebug.c
    gcc -o 80211debug -g -O2 -Wall -I. -I../hal -I..  80211debug.c
    gcc -o wlanconfig -g -O2 -Wall -I. -I../hal -I..  wlanconfig.c
    gcc -o ath_info -g -O2 -Wall ath_info.c
    make[1]: Leaving directory `/root/Desktop/madwifi-0.9.4/tools'
    bt madwifi-0.9.4 # make install
    sh scripts/
    for i in ath/ ath_hal/ ath_rate/ net80211/; do \
                    make -C $i install || exit 1; \
    make[1]: Entering directory `/root/Desktop/madwifi-0.9.4/ath'
    test -d //lib/modules/ || mkdir -p //lib/modules/
    for i in amrr/ onoe/ sample/ minstrel/; do \
                    make -C $i install || exit 1; \
    make[2]: Entering directory `/root/Desktop/madwifi-0.9.4/ath_rate/amrr'
    test -d //lib/modules/ || mkdir -p //lib/modules/
    wlan_xauth.o wlan_scan_sta.o wlan_scan_ap.o; do \
                    f=`basename $i .o`; \
                    install $f.ko //lib/modules/; \
    make[1]: Leaving directory `/root/Desktop/madwifi-0.9.4/net80211'
    (export KMODPATH=/lib/modules/; /sbin/depmod -ae
    make -C ./tools  install || exit 1
    make[1]: Entering directory `/root/Desktop/madwifi-0.9.4/tools'
    install -d /usr/local/bin
    for i in athstats 80211stats athkey athchans athctrl athdebug 80211debug wlanconfig ath_info; do \
                    install $i /usr/local/bin/$i; \
                    strip /usr/local/bin/$i; \
    install -d /usr/local/man/man8
    install -m 0644 man/*.8 /usr/local/man/man8
    make[1]: Leaving directory `/root/Desktop/madwifi-0.9.4/tools'
    bt madwifi-0.9.4 # iwconfig
    lo        no wireless extensions.
    eth0      no wireless extensions.
    And the pre-compiled package:
    bt~#installpkg Desktop/madwifi-0.9.4_2.6.21.5_smp-i486-1-.tgz
    Installing package madwifi-0.9.4_2.6.21.5_smp-i486-1-...
    Package Description:
    madwifi: madwifi (driver for atheros based wireless a/b/g cards)
    Executing install script for madwifi-0.9.4_2.6.21.5_smp-i486-1-...
    bt~# iwconfig
    lo           no wireless extensions.
    eth0        no wireless extensions.
    Did I miss a step after anything? As I said I am completely new to slackware but I will do anything to get the wifi working, even if i have to use something like ndiswrapper.


  2. #2
    Just burned his ISO
    Join Date
    Jul 2009


    I do not have much experience with slackware but still this may help.


    root@xyz:~# airmon-ng
    Interface       Chipset         Driver
    wlan0           Intel 3945ABG   iwl3945 - [phy0]
    wlan1           ZyDAS 1211      zd1211rw - [phy1]

    do you get a result of this sort. if so

    iwconfig wlan0 essid WiFi mode managed key whatever-your-key-is
    dhclient wlan0
    if you get a ping you are set

    Hope this helps

  3. #3
    Super Moderator lupin's Avatar
    Join Date
    Jan 2010


    I don't see any command to load the ath_pci module in either of those steps you outlined above. You will need to make sure the module is loaded before the device is recognised by the system and the card will show up in the output of the iwconfig command.

    The command to load this module is actually provided in MadWifi link you said you were following.
    Capitalisation is important. It's the difference between "Helping your brother Jack off a horse" and "Helping your brother jack off a horse".

    The Forum Rules, Forum FAQ and the BackTrack Wiki... learn them, love them, live them.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts