Alright guys so I downloaded the pre release of BT4 and got it all installed on my USB working fine. I was hanging out with my friend and showing it to him on my Acer Aspire One and he decided he wanted it on his USB so I ran the from my USB and installed it onto his, and everything seemed to be working except I forgot to change the grub to install to his USB instead of my hard drive. Now when ever I boot up my computer i get a Grub 1.5 Error 21 and I cannot fix it or boot back up into Windows. After googling for hours I finally found a way to get a recovery console onto a USB (my netbook doesn't have a cd drive) and I ran a combination of commands such as fixmbr, fixboot, and BOOTCFG /rebuild and still nothing has changed. I tried using Ubuntu and installing the MBR through that but that didn't work either, I'm still getting the Error 21 and Grub won't go away. Any help would be great because the only option I see left is to reinstall windows which is not something I want to do. Thanks a lot