Hi guys, lately, if I want to update svn programs I`ll also keep another copy in tar.gz so if I switch to bt3
I havent to update it again.

In bt3 however, if I uncompressed them, svn cleanup;svn update, I got this output:

svn: This client is too old to work with working copy '.'; please get a newer Subversion client
So I tried to download the latest version from the tigris but still no luck...

bt ~ # svn --version
svn, version 1.4.4 (r25188)
compiled Jun 12 2007, 00:06:25

bt ~ # cd subversion-1.6.3
bt subversion-1.6.3 # ./configure

config.status: executing svn_private_config.h commands
configure: WARNING: we have configured without BDB filesystem support
You don't seem to have Berkeley DB version 4.0.14 or newer
installed and linked to APR-UTIL. We have created Makefiles which
will build without the Berkeley DB back-end; your repositories will
use FSFS as the default back-end. You can find the latest version of
Berkeley DB here:
bt subversion-1.6.3 # make
usr/bin/sed: can't read /usr/lib/libdb-4.4.la: No such file or directory
libtool: link: `/usr/lib/libdb-4.4.la' is not a valid libtool archive
make: *** [subversion/libsvn_subr/libsvn_subr-1.la] Error 1
How do I install/upgrade the latest subversion (or later) properly?

Thank you.