Before I start with my question, I'd just like to say first, I've searched google and this site, and cannot find solution for my exact problem (or maybe I just don't understand it). Secondly, after reading and browsing this forum it seems like a friendly, very helpful, well ran site. BT is an awesome program and I appreciate the hard work that goes into it to make it. Thank you in advance for taking the time to try and resolve me problem =).

I'm trying to crack my own wep. This is the steps i've taken

1. airmon-ng
2. airmon-ng stop
3. ifconfig ith1 (my wireless card) down
4.macchanger --mac 00:11:22:33:44:55 ith1
5. airmon-ng start ith1
6. airodump-ng ith1
7. Find a wep to crack (my own)
8 airodump-ng -c (what channel my wep is) -w (random file name) --bssid (my bssid) ith1 new shell
10. aireplay-ng -1 0 -a (my bssid) -h 00:11:22:33:44:55 ith1 (i've also tried -e then the essid, making sure to add caps or no caps, then adding my ith1 card after that, doesn't work, I get the same error)

This step is where I get the error:

the interface MAC x:x:x:x:x doesn't match the specified mac (-h). Ifconfig ith1 hw ether 00:11:22:33:44:55