well running the new backtrack 4 pre-final release i kinda had a problem with the wifi it didnt seem to work. well not for wpa2-ccmp. i know backtrack already have the driver already install but no go. i swear i tried everything modprobing to the ifconfig to trying the ralink legacy still no joy.

so i fixed it...

what you do is:
1) download the rt2860sta driver


2) extract it normally, now cd into the folder "cd 2009_0521_RT2860_Linux_STA_V2.1.2.0"

3) then cd in to "os/linux" and "nano config.mk"

4) change the values of these lines (its at the top kinda confusing). so it looks like this:



5) then just cd back out until your in the root directory of the folder "2009_0521_RT2860_Linux_STA_V2.1.2.0" okay before you type "make && make install" you have to change the kernel file "rt2860sta.ko to rt2860sta.bak." Okay so open new terminal and type:

cd /lib/modules/

mv rt2860sta.ko rt2860sta.bak


6) okay now go back to the other terminal now run " make && make install"
then "modprobe rt2860sta" then "ifconfig ra0 up"

7) "reboot"
yes i said reboot for some odd reason wicd didnt reconfigure for ra0. dunno why i did the refresh and a couple of other things but no go. After reboot it should work. Sorry for the long tutorial but i got the wifi working and the spacing my bad i decided to do it that way because it seemed to better on the eyes.

"P.S. The new kernel update from BackTrack fixes the problem"