I was trying to get the announced nvidia-drivers from the remote-exploit repository using apt-get (I got BT4 pre Final).

The package is called "backtrack-nvidia"

Everything seemed to go the usual way, when at the end of the installation process it stopped and gave me the following output

subprocess dpkg returned error code (1)
This occured when it tried to install the package "nvidia-drivers".

I googled it, and found some things, but there the problem was low disk space, that's definately not the case with me!
I also tried to re-install from live-cd (about 4-5 times) and then used different approaches in the update-process...

I just can't find any clues on how to fix this error..

I also tried:

dpkg-reconfigure -a
since this seemed to fix the dpkg in another problem (read that when I was researching the problem). In my case this didn't solve it either..

Now everytime I decide to try again, apt-get won't work (only the update works) and it tells me to run it using

apt-get install -f
When I tried that, same Error occured.

I also thought this might be a apt error so I tried aptitude as well with the same errors..

I feel really lost now... Any clues or help would be greatly appreciated.

My Hardware:

Dell D830 Notebook
Nvidia Quadro NVS Series (notebook) 140M

Well since no one had an idea yet, I've decided to post more of my output in here..

Unpacking nvidia-driver (from .../nvidia-driver_185.18.08-bt4_i386.deb)
dpkg: error processing /var/cache/archives/nvidia-driver_185.18.08-bt4_i386.deb (--unpack):
trying to overwrite /usr/include/GL/gl.h' , which is also in package mesa-common-dev
Processing triggers for man-db ...
Error were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
If I am using the apt-get as root (and not be running X!) it should be able to overwrite the file in the above output.. (As far as I figure it)..

So has anybody any ideas or hints now?


I have now tried to move the file which was unable to be overwritten to a different location. Tried to fix it again using the "apt-get install -f" and still had the same error.
Then I figured maybe the package mesa-common-dev could be removed prior to the installation of the nvidia-driver, but how can I "clean" apt-get? It tells me I need to take care of the nvidia-driver problem first.
Last try was to "touch" a new gl.h into the directory and still I had the same error...

I'm going in a new direction (tried to "think outside the box"). I reinstalled bt4 to my harddrive to fix my apt-get. Now I will try to compile some older drivers first and then do a new update (so hopefully, it will be replaceable by the backtrack-nvidia drivers).
I'll keep posting my results, if someone has and idea tho, feel free to suggest.

Turns out I ran into some more trouble when trying to compile any packages... It tells me the kernel-headers are missing...
I googled than and found a post refering to this on this forum:
So now I'm on this problem...

While doing some more research I found someone with similiar error in the dpkg:

*Hope this will help someone with the same errors*

************************************************** *****************************

When dpkg returns errors while updating/installing something on the system, this means the file can't be overwritten. In most cases you can solve this problem if you just move the file away and try again!