Page 2 of 6 FirstFirst 1234 ... LastLast
Results 11 to 20 of 52

Thread: RT2870 BT4 Guide (working!!!)

  1. #11
    Just burned his ISO
    Join Date
    Apr 2009


    my congratulation guys for new alfa
    so we can give the new device 10/10 working and better than previuos model ? or still under test ?
    [CENTER][COLOR="Red"] :: iF YOu hAvE nO iDeA aBoUt mE, pReSS F1 fOr hElP :D :: [/COLOR][/CENTER]

  2. #12
    Junior Member Jano's Avatar
    Join Date
    Jan 2010


    Excuse me,
    - Error post: I did a double post (

    Wireless: ALFA-AWUS036H, AWUS050NH, D-Link DWL-G650, D-Link DWL-G122, ZyXel G220, Linksys WUB54GR, Intel PRO/Wireless 3945ABG

  3. #13
    Just burned his ISO
    Join Date
    Jun 2009


    Is there any chance that this modified (enhanced imho) driver will be sent upstream?

  4. #14
    Just burned his ISO
    Join Date
    Jun 2009


    1st post, apologies in advance!

    this is all good, i got this driver working for my Belkin F5D8053 in BT4. thanks for that.

    iwconfig reports the RT2870 driver fine.


    query 1:
    when i run "airmon-ng start ra0" i get
    interface: ra0
    chipset: Ralink 2560 PCI
    driver: rt2500 (monitor mode enabled)

    is this normal? i was expecting more RT2870 responses.

    query 2:
    when i run "airodump-ng ra0" i seem to get very patchy results. my target network is on chan 11, but i don't get any results for chan 11, just 1-6. i also get quite a few "Invalid truesize" errors. googling suggests these can be ignored, but is this indicating another problem?

    query 3:
    when i run "airodump-ng -c 6 -b <bssid> -w <filename> ra0" with a relevant bssid and filename, i get "channel range already given" and weird results from channels 1-6 along with the Invalid truesize errors. which seems a bit weird?

    query 4:
    when i run "airmon-ng stop ra0" the kernel seems to crash. which i'm desperately guessing might be something to do with the rt2500/2560/2870 conflict above.

    i'm a noob so apologies if some/all above problems are in the wrong thread, but any pointers would be appreciated.

    let me know if i should supply more info.

    i'm guessing that the belkin antenna is just terrible and i should buy one of these nice alfa adaptors instead. is this a reasonable conclusion?

  5. #15
    Junior Member
    Join Date
    Feb 2009


    try using the rt2x00 driver, guide posted here

    people here have been getting better results than my current driver, though the problems you have may be device specific, i've heard of some slight channel problems but none so severe as to restrict to 1-6

  6. #16
    Just burned his ISO
    Join Date
    Jun 2009


    thanks, that driver worked out much better for me.

    i solved most of my problems, but your driver was giving me very strange channel results. most of the time i could only see channels 1-6. iwconfig always reported the correct frequency. on a particular boot i was able to see channel 11 networks, but only when scanning channels 8 and 12.

    i understand why a lot of noob messages are answered with "you're a noob. stop using backtrack and use ubuntu." backtrack is not for beginners!

    anyway, thanks again.

  7. #17
    Just burned his ISO
    Join Date
    Jul 2009

    Default Alfa Network

    Quote Originally Posted by fnord0 View Post
    that makes me glad too! heheh

    ok = "warning blinders" ON

    oh, oh - me too, me too! heh, I really wanna work on recompiling with the new wireless drivers too (I also looking to try the rt2800usb driver from compat-wireless but that isn't panning out so good either ... yet) - so I will be trying this right along side you guys... I thinking of hitting the good `ol IRC to see if I can get me some help with this. so yeah, I am gonna try the same. thanks for everything!

    Salve a tutti,

    Ho acquistato una scheda wireless alfa network con chipset rtl (non ricordo il numero) comunque il modello Ŕ: AWUS036H. Vorrei provare la stabilitÓ della mia wireless, e pensavo di adoperare aircrack, qualcuno mi sa aiutare ??? per i primi passi per poterla configurare con i driver giusti ??? Grazie, aspetto al pi¨ presto na vostra risposta, grazie.

  8. #18
    Just burned his ISO
    Join Date
    Feb 2009

    Default About my WUSB600N

    i have the WUSB600N usb wich is the rt2870 chipset, now i downloaded the apocolypse driver, then edited the correct file for adding my device id, i did the sudo make && make install on backtrack4 live cd, and i get a error near the end, now here's the weird part. i did ifconfig ra0 and it shows it's actively installed, now when i try airodump-ng ra0 it only shows me two of the total -8- local ap's and those two are only wpa,wpa2. i don't know if its the new kernel or the driver that was written for the chipset, but it seems broken in backtrack4 and the nemesis driver is the only working one and that alone only works with wifislax 3.1 and backtrack 2final(again probably because of the kernel)

    edit: oh yeah and i added this exact device id to the rt2870.h source file
    {USB_DEVICE(0x1737,0x0071)}, /* LinkSys WUSB600N */ \
    this is exactly what nemesis had put into his rt2870.h file for the WUSB600N

    also my card is working great right now on a HDD install of bt2 with the nemesis driver, i have no usb problems nor any dying or erronous wifi stick problems.soooo basically i would like to know what went wrong between the driver(both nemesis and apocolypses fix) and bt3 and bt4. any resolution on the subject would be much appreciated.(and apocolype was right, the sh*tty driver from the ralink website don't work for turds)

  9. #19
    Just burned his ISO
    Join Date
    Jul 2009


    Please help. I have followed your instruction but ... : (I need the driver for Zioncom WL0162)

    root@bt:~/rt/rt2870-2.6.27-apocolipse# make
    make -C tools
    make[1]: Entering directory `/root/rt/rt2870-2.6.27-apocolipse/tools'
    gcc -g bin2h.c -o bin2h
    make[1]: Leaving directory `/root/rt/rt2870-2.6.27-apocolipse/tools'
    cp -f os/linux/Makefile.6 /root/rt/rt2870-2.6.27-apocolipse/os/linux/Makefile
    make  -C  /lib/modules/ SUBDIRS=/root/rt/rt2870-2.6.27-apocolipse/os/linux modules
    make[1]: Entering directory `/usr/src/linux-source-'
      WARNING: Symbol version dump /usr/src/linux-source-
               is missing; modules will have no dependencies and modversions.
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../common/md5.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../common/mlme.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../common/rtmp_wep.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../common/action.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../common/ba_action.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../common/cmm_data.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../common/rtmp_init.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../common/rtmp_tkip.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../common/cmm_sync.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../common/eeprom.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../common/cmm_sanity.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../common/cmm_info.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../common/cmm_wpa.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../common/dfs.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../sta/assoc.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../sta/aironet.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../sta/auth.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../sta/auth_rsp.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../sta/sync.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../sta/sanity.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../sta/rtmp_data.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../sta/connect.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../sta/wpa.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../os/linux/rt_linux.o
      CC [M]  /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../os/linux/rt_profile.o
    /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../os/linux/rt_profile.c: In function 'RTMPReadParametersHook':
    /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../os/linux/rt_profile.c:778: error: 'struct task_struct' has no member named 'fsuid'
    /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../os/linux/rt_profile.c:779: error: 'struct task_struct' has no member named 'fsgid'
    /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../os/linux/rt_profile.c:780: error: 'struct task_struct' has no member named 'fsuid'
    /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../os/linux/rt_profile.c:780: error: 'struct task_struct' has no member named 'fsgid'
    /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../os/linux/rt_profile.c:1369: error: 'struct task_struct' has no member named 'fsuid'
    /root/rt/rt2870-2.6.27-apocolipse/os/linux/../../os/linux/rt_profile.c:1370: error: 'struct task_struct' has no member named 'fsgid'
    make[2]: *** [/root/rt/rt2870-2.6.27-apocolipse/os/linux/../../os/linux/rt_profile.o] Error 1
    make[1]: *** [_module_/root/rt/rt2870-2.6.27-apocolipse/os/linux] Error 2
    make[1]: Leaving directory `/usr/src/linux-source-'
    make: *** [LINUX] Error 2

  10. #20
    Just burned his ISO
    Join Date
    Jul 2009


    Yoo...I am using the RaLink RT2870 USB dongle with your patched driver. My platform is Ubunto kernel updated with build-essential.

    When I started airodump-ng ra0, it showed no Power level but everything else seemed to be working alright.

    What seems to be the problem?

Page 2 of 6 FirstFirst 1234 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts