I'm trying to get BT4 installed locally. I watched the video about using Ubiquity to do it. However, it appears that they lied. It said that they booted to the CD, and then just typed Ubiquity and it worked. Not true.

First, Ubiquity is not found on the ISO, in memory or anywhere else. You have to do an apt-get install to get Ubiquity working. Then of course, you run into the issue where Ubiquity crashes when it can't set the language.
(problem described here: https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/189193 )

Now being a Linux/Ubuntu n00b I am having trouble in two areas. First, when you boot to the iso, there is no /media/cdrom mounted on a physical machine, or on a Virtual Box machine (tried VMWare and Virtual PC 07 as well, same results). So you can't just point Ubiquity to the source files it needs. Additionally I also can't fine the .../casper/filesystem.squashfs stuff to mount on /var/lib/ubiquity/source anywhere either.

Since one of the alternative ways to get Ubiquity to work is to run it from the cdrom rather than manually mount the above files, it would be good if Ubiquity was actually included on the bootable iso so you could run it from the cdrom.

Can anyone tell me how to either, find and mount the filesystem.squashfs, or magically run Ubiquity from the 'cdrom' iso?