I seem to have an issue with the metasploit auto_pwn.
I referenced the steps provided by HD and everything seems to work the way it should until I try to access the interactive shell.For example

f > sessions -l

Active sessions

Id Description Tunnel
-- ----------- ------
1 Command shell -> x.x.x.x:26358

Lets me know that I have an active shell and I should just be able to interact with that particular session via the "sessions -i 1" command but instead of a command shell it just freezes up by displaying nothing or will just close the session altogether.Has anyone seen anything like this before?

msf > sessions -i 1[*] Starting interaction with 1...

[*] Command shell session 1 closed.
msf > sessions -i 2[*] Starting interaction with 2...

[*] Command shell session 2 closed.
msf > sessions -i 3[*] Starting interaction with 3...

[*] Command shell session 3 closed.
msf > sessions -i 4[*] Starting interaction with 4...

I have tried this on multiple hosts that I have here on my LAN as well as hosts assigned with external IP addresses and I get the same result.I checked my routers connection logs and it does show that in fact that there is a connection between by local host and the remote system so I am at a loss as to what could be wrong here.There is not any firewalls issues that I am aware of on my side so I am wondering is there some kind of issue with my ISP that I am not aware of.If you need more details let me know and I will provide them.

Thanks Secure111