Results 1 to 2 of 2

Thread: No display | nVidia / AMD-nForce, BT4-usb

  1. #1
    Just burned his ISO
    Join Date
    May 2009

    Default No display | nVidia / AMD-nForce, BT4-usb

    Hi guys, I'm hoping that somebody can point me in the right direction.

    I've been working this problem for several days; I want to say first off that I've found the forums to be a generous and invaluable resource while trying to figure this out.

    That being said...

    The setup:

    I'm running the following system: AMD64(dual) / nForce-based MB (ASUS SLI w/ an older nVidia 6800 card). I'm tri-booting Vista Ultimate, Windows 7, and BT4 (running BT4-beta on an old 10GB laptop drive in a USB enclosure - 1GB win32 partition, the rest is ext2 - typical unetboot install with persistence).

    Everything boots fine using BCD/lilo.

    The current situation:

    Black screen after 'startx'. I can hear the M-K audio so I'm assuming the desktop is in fact loading but the display dies.

    What I've tried:

    I began with all sorts of display issues, most of which are solved at this point (parse errors, no screens, etc).

    fixvesa (did not work)
    Xorg edits (tried to force modeline; did not work)
    downloaded and sh new pkg ( - install went fine, but did not solve problem)

    Any thoughts?

    I'm still pretty much the noob, but think if I can get some quick guidance I can figure out the rest (and yes, I've been through the forums, Google, etc - lots of results, but nothing's worked yet).

    Many thanks.

  2. #2
    Just burned his ISO
    Join Date
    May 2009

    Smile nVidia Fix

    Thought I'd answer my own post (having come across multitudes with similar issues while researching a fix - okay, maybe not multitudes, but certainly hordes.

    What worked for me, after completing a dual-boot HD install (vista/bt4)...

    1) xorg -configure
    2) dpkg-reconfigure xserver-xorg

    NOTE: Though I never received Screen configure options, only keyboard layout; when I neglected this step... no working video.

    3) lspci

    NOTE: Write down the bus ID and exact vendor label as listed. For example:

    01:00.0 VGA compatible controller: nVidia Corporation NV42 [GeForce 6800 XT] (rev a2)

    4) nano /etc/X11/xorg.conf
    5) There will be 3 generic listings. Edit the Device listing to reflect your configuration. In my case I added the following information:

    Identifier: "nVidia Corporation NV42 [GeForce 6800 XT] (rev a2)"
    Driver: "vesa"
    BusId: "PCI:1:0:0"
    Option: "UseFBDev" "true"

    6) Save and exit

    I was now be able to startx successfully. At which point I promptly downloaded the nVidia driver package and installed.


    7) sh (allow the installer to create a new xorg.conf file)

    8) nano /etc/X11/xorg.conf Add modes in Screen listing to support your desired display resolution, in my case:

    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24

    SubSection "Display"
    Depth 24
    Modes "1152x864"

    And that's it. Hopefully this may help someone also working through nVidia display issues...

    Best, bez.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts