Thank you all for your help.

So I have tried to removed the old drivers and then reinstall new drivers using Aircrack
site but still whenever I run iwconfig, unable to see any wireless card in my VM. One thing I have notice that some of people have recommended running ifconfig eth0 up but my virtual machine already has bridge connection using physical NIC and it is using bridge settings, so whenever I run ifconfig, I do see my bridge connection is pulling a proper IP address.

Do I need to disable my bridge connection, in order to get wireless detected as eth0?