Results 1 to 6 of 6

Thread: Freeze after X starts.

  1. #1
    Just burned his ISO
    Join Date
    Mar 2010

    Question Freeze after X starts.

    I haven't found any solution to the problem I encountered today. I followed this video tutorial to instal BT4 to my 4GB PQI flash drive. Everything went OK.

    I edited the .bash_profile
    /etc/init.d/wicd start

    I can't work out, why does my Backtrack freeze after the X starts - mouse and touchpad not responding. Sometimes it boots up normally, more often not. I would appreciate any suggestions.

    The second problem concerns very famous issue - wicd. I've read all related posts here, but none seems to be helpful. Important fact is that - it worked for me for some time on the above instalation, but suddenly it stopped showing up in the tray. I tried almost everything I could:
    /etc/init.d/wicd start
    /usr/bin/wicd-client on
    update-rc.d wicd defaults

    It still doesn't show up. What to do? How to check whats' wrong?

    Thanks in advance for any constructive help.

  2. #2
    Join Date
    Feb 2010

    Default Re: Freeze after X starts.

    i think a good place to start would be telling people what hardware you are using... then searching the same hardware for issues here... or google "my hardware xwindows crash ubuntu" and see if that helps you resolve the issue ...same for the debian/ubuntu wireless network wizard thing.

    you might also see some error logs the easy way by hitting CTL+ALT+BACKSPACE it should dump x and you should see some crash on the screen... but more then likely you just have some hardware incompatibility with the default configuration of x.conf etc.. which will need some research.

  3. #3
    Just burned his ISO
    Join Date
    Feb 2010

    Default Re: Freeze after X starts.


    Not sure how helpful this will be to you, but after you start WICD did you try accessing it via the GUI? Go to the BT menu and click on internet, you should see an icon for WICD click that (after you run (with root privileges)
    /etc/init.d/wicd start
    Maybe you can try updating your system? Thats the little input i could provide, sorry

    not sure about the start-x issue, works fine for me

  4. #4
    Senior Member lordplagueis's Avatar
    Join Date
    Jan 2010

    Default Re: Freeze after X starts.

    have you tried this for your second issue
    HP DV7
    8GB DDR3
    Core i7-720QM
    Nvidia GeForce GT 320M

    BT5-64bit x WIN7-64bit DualBoot

  5. #5
    Just burned his ISO
    Join Date
    Mar 2010

    Default Re: Freeze after X starts.

    Thank you for your replies.

    I logged to the BT today (mouse is not working at all now, no matter how many times i boot the system up). Tried to push CTRl+ALT+DELETE, but nothing happened.

    However, i've hit windows combination of CTRL+ALT+DELETE which brought me to the terminal (?, the one which you see before starting X). I think that might be the cause my problem:

    BackTrack 4 (PWNSauce) Penetration Testing and Auditing Distribution
    Starting Network connection manager: wicd.
    X: warning: process set to priority -1 instead of requested priority 0

    Fatal server error:
    Server is already active for display 0
    If this server is no longer running, remove /tmp/.X0-lock
    and start again.

    Any ideas now?

  6. #6
    Junior Member timcki's Avatar
    Join Date
    Jan 2010

    Default Re: Freeze after X starts.

    To get get back into X hit ctrl+alt+F7.....

    That error message is telling you what is going on..
    you entered a virtual terminal outside of X.

    as far as your lockup problem, I had a wireless card that if i did a: ifconfig wlan0 up it would lock up the system hard.
    I too was trying to automatically start wicd which would start in the background then BAM!!! lockup
    Once I disabled wicd at startup X would run fine... Until I manually tried to start wicd... lockup again.
    all of my lockups did not write an error to /var/log/messages...
    Once I narrowed it down to wicd , I tried a different wireless card and all worked fine....

    Check your system hardware and see if you have any config/conflicts in your system
    Just because you don't agree with it doesn't make it stupid

Similar Threads

  1. Wicd manager starts up, and closes after 5 seconds...
    By jacobtc in forum Beginners Forum
    Replies: 11
    Last Post: 02-25-2010, 07:27 PM
  2. Burp freeze
    By McFranco in forum BackTrack Bugs
    Replies: 2
    Last Post: 02-20-2010, 11:23 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts