Results 1 to 10 of 10

Thread: No ath0 wifi0 on my Aspire1 BT4b

  1. #1
    Just burned his ISO
    Join Date
    May 2009

    Talking No ath0 wifi0 on my Aspire1 BT4b


    I've got an aspire1 D150-1bGb with winXp pre-installed
    and have a BT4 installed on a USB

    BT4 doesn't seem to recognize my wireless card easily as the case was for BT3
    ruining ifconfig shows only my eth0 and lo
    i tried to ifconfig ath0 up , ifconfig wifi0 up , changed the zeros with ones
    they all give a no such device error.

    iwconfig shows lo, eth0, hso0 with no wireless extensions.

    I have started the networking services , along with the NetworkManager to try the KNetworkManager < but also this one doesn't seem to work at all.

    i don't really know what I have missed but hope to get some guide here.

    I have googled all over the net for compatibility issues between my aspire and bt4 and other Linux distributions , there seems no issues
    I have read lots of articles here and tried many solutions before asking,


  2. #2
    Good friend of the forums
    Join Date
    Feb 2009


    /etc/init.d/networking start
    /etc/init.d/NetworkManager start

  3. #3
    Member kazalku's Avatar
    Join Date
    Feb 2009


    I think he already did this.
    Quote Originally Posted by Mo9a7i View Post
    I have started the networking services , along with the NetworkManager to try the KNetworkManager < but also this one doesn't seem to work at all.
    If you can't explain it simply, you don't understand it well enough -- Albert Einstein

  4. #4
    Super Moderator lupin's Avatar
    Join Date
    Jan 2010


    Have you tried booting with another live cd (Ubuntu, Knoppix, whatever) to see if that detects your wireless card?

    Do you know what type of wireless card is in the pc? Have you tried lspci to find out what the wireless device is named (assuming its a pci device) and then searched based on that device name?
    Capitalisation is important. It's the difference between "Helping your brother Jack off a horse" and "Helping your brother jack off a horse".

    The Forum Rules, Forum FAQ and the BackTrack Wiki... learn them, love them, live them.

  5. #5


    Have you tried "lscpi -vv" to see if the card is even seen by the system?

    If it is, try "lsmod" to see if there are any atheros modules loaded.

    If not, try either:

    modprobe ath5k
    modprobe ath9k

  6. #6
    Just burned his ISO
    Join Date
    May 2009


    I have the same problem... basicly my device is disabled (hardware switch is off and it is not responding) when i put iwconfig it shows me:

    no wireless extensions

    when I put lsmod it shows me:

    Module Size Used by
    ipv6 227680 10
    snd_seq_dummy 3084 0
    snd_seq_oss 30720 0
    snd_seq_midi_event 5888 1 snd_seq_oss
    snd_seq 44016 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
    snd_seq_device 6668 3 snd_seq_dummy,snd_seq_oss,snd_seq
    snd_pcm_oss 42048 0
    snd_mixer_oss 15232 2 snd_pcm_oss
    pcmcia 31272 0
    yenta_socket 24476 0
    rsrc_nonstatic 11276 1 yenta_socket
    pcmcia_core 34488 3 pcmcia,yenta_socket,rsrc_nonstatic
    nls_utf8 1920 2
    capability 3468 0
    commoncap 5376 1 capability
    fuse 38804 0
    agpgart 27952 0
    lp 9928 0
    parport_pc 24548 0
    parport 30408 2 lp,parport_pc
    psmouse 35616 0
    snd_hda_intel 17080 4
    ath_pci 88636 0
    snd_hda_codec 198064 1 snd_hda_intel
    wlan 190916 1 ath_pci
    snd_pcm 68752 4 snd_pcm_oss,snd_hda_intel,snd_hda_codec
    tg3 104328 0
    ath_hal 189776 1 ath_pci
    sdhci 16408 0
    i2c_i801 7180 0
    sg 27304 0
    mmc_core 20884 1 sdhci
    snd_timer 19336 3 snd_seq,snd_pcm
    i2c_core 17680 1 i2c_i801
    snd 44644 14 snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,s nd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_hda_cod ec,snd_pcm,snd_timer
    ehci_hcd 29336 0
    shpchp 30240 0
    soundcore 5984 2 snd
    ohci1394 31284 0
    snd_page_alloc 7816 2 snd_hda_intel,snd_pcm
    ieee1394 84576 1 ohci1394
    uhci_hcd 21140 0
    ata_generic 5256 0
    evdev 8320 0
    serio_raw 5380 0
    pcspkr 2432 0
    nls_iso8859_2 4608 0
    nls_iso8859_1 4096 0
    nls_cp437 5760 0
    aufs 83888 1
    squashfs 44680 10
    sqlzma 3204 1 squashfs
    unlzma 4352 1 sqlzma

    but I dont know how to switch it on

  7. #7
    Senior Member streaker69's Avatar
    Join Date
    Jan 2010
    Virginville, BlueBall, Bird In Hand, Intercourse, Paradise, PA


    In some machines, there's a setting in the BIOS to always enable the Wireless card and not use the switch that's on the machine.
    A third party security audit is the IT equivalent of a colonoscopy. It's long, intrusive, very uncomfortable, and when it's done, you'll have seen things you really didn't want to see, and you'll never forget that you've had one.

  8. #8
    Just burned his ISO
    Join Date
    May 2009


    strange I do not have this problem with ubuntu or mandriva

  9. #9
    Just burned his ISO thecheekymonkey's Avatar
    Join Date
    Jan 2010


    did this ever get sorted out, i`m having exactly the same problems?


  10. #10
    Developer muts's Avatar
    Join Date
    Jan 2006


    Without knowing the chipset, a dmesg and an lspci, its very difficult to know what the issue is.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts