1) I am a newb, and learning Linux (big surprise right)
2) I was able to muddle through BT3 and it works, I'm only posting this because I rarely give up (OCD). BT3 works fine but wesside-ng looks like it's whole lot quicker and I'd like to see it in action so-to-speak.
3) I have searched and researched for hours, if this was already discussed somewhere else I apologize.

Toshiba A123, Atheros Wireless, ATI Radeon Xpress 200m

Made bootable thumb drive. The boot up process seems fine, login (root/toor), run startx and I briefly get a blinking cursor, then the display shuts off (black screen). I've found several threads in various places that lead me to believe this is Video driver issue. I've tried numerous things like (ctrl+backspace) to exit, ctrl+alt+minus, ctrl+alt+plus, tried to edit the xorg.conf file which appears to be empty, tried executing xorgconfig, xorg - config, xorgconf, xorgsetup but none of these seem to exist. I know this is beta but if it's just a matter of adjusting the display settings...

Thanks for any advice or pointers.