I am trying to install BT4 onto a USB. I have done so by copying the Boot and BT4 folders from the ISO file to a fat32 partition then running the bootinst.sh in Ubuntu 9.04 and also tried running bootinst.bat in WinXP. Also I have tried using Unetbootin by copying the ISO image to a fat32 partition on my USB.
I was able to boot to BT4 successfully, however durning startup the "Activating swapfile" fails. This annoys me for 1. because the "Activating Swapfile" is OK when I boot from a CD but if I boot from the USB in either of the 3 ways I created the USB from above I can't get the "Activating swapfile" to be OK.
I tried partitioning my USB in different ways 1.1 fat32 partition then the rest is ext2. 2. fat32 partition, then with a linux extended partition which was made up of an ext2 and linux-swap. 3. Also tried creating a fat32, then a second parition ext2 then a seperate third as linux-swap. 4. Partitioned the whole drive as linux extended and put in a fat32 and an ext2 and a linux-swap inside.
I still can't get the damn "activating swapfile" to be successful. BT4 seems to work even though it fails but I don't like it. Plus i don't understand how a read-only DVD can have the swapfile successful but a writeable flash drive fails. I would like to understand how this is so but I couldn't find any info. As I don't like posting in forums.
Also I know that flash drives have limited read/writes but that's beside the point.
My last resort now is to boot from the CD then treat my flash drive as a HDD and set it up like it's a single boot install.
If anyone has any info on the swapfile please let me know. Again I want to mention the the Activating swap is succesfull in all cases but just the "activating swapfile" fails when booting from the usb.