I just got this adapter in the mail today, and I was extremely excited because I've been really frustrated with my other adapter recently. So I loaded up BT3 in VMWare, because I had heard that this card works out-of-box with VMware. So I was mid-way into cracking my own WEP key, and when I did the

"aireplay-ng -1 0 -a xx:xx:xx:xx:xx wlan0"

VMware suddenly told me that the adapter had been disconnected, and consequently, XP was telling me that it had found new hardware. So, I didn't really understand this because it had never happened before, but when I went back to look at Backtrack there had been an error.

All I had done up until that point was

"airmon-ng stop wlan0"
"ifconfig wlan0 down"
"macchanger --mac 00:11:22:33:44:55 wlano"
"airmon-ng start wlan0"
"airodump-ng -c 6 -w Network --bssid ##:##:##:##:##:## wlan0"

So after I got these errors I tried going back to step one and re-doing the whole process, but I eventually realized that there was something VERY wrong.

So then I tried BT4b, and I was having similar problems, but NOW airodump-ng wouldn't even work, I was getting a SIOCSIFFLAGS error.

THEN I tried to install the windows drivers and see if it would connect to my network on Windows AT ALL, and as soon as it was set up, the adapter kept ENABLING and DISABLING itself, like... every 3 seconds.

So THEN I figured VMWare might be the problem, so I burned the BT3 live disc and tried that but it turns out that my current PC only works with the "acpi=off noapic" option, which seemed to seriously mess some stuff up during the boot phase, and the "startx" command yielded a bunch of errors.

So since then, I've tried updating the windows drivers, just to see if I can figure it out on windows before I go to Linux, but I still got nothing.

Defective hardware? I'm really at a loss guys and I'm really upset that it didn't work out-of-box like it was supposed to. lol.

I've seen in a couple threads that I might need to update the drivers, but if I do that, and it still doesn't work, and then I decide to send it back in to see if I can get a new one, will they care?

Also, what could I have possibly f'd up that made it this way?

Thanks a lot,