Hello, first off I'd just like to say I'm glad to have joined the forums, I've been reading for a couple years now but never bothered to actually join until now...

Anyways, running BT3 off of an SD card on an Asus EEE 900HA, I am unable to connect to any AP after spoofing my MAC address, whether I am connecting from Konsole or the Wireless Assistant. I have tried several different variations of doing it, such as

wlanconfig ath0 destroy
ifconfig wifi0 down
macchanger --mac 00:11:22:33:44:55 wifi0 (i have tried ath0 as well)
wlanconfig ath0 create wlandev wifi0 wlanmode managed
ifconfig ath0 up
ifconfig wifi0 up
I have also tried

ifconfig ath0 down hw ether 00:11:22:33:44:55
ifconfig ath0 up
and a few other variations, all to no avail. Some attempts even leave me with a "connection failed" message from the Wireless Assistant immediately after trying to connect. However, I did notice that as soon as I have logged in to BT3, I am already connected to my neighbor's open AP. Could this be somehow contributing to my problem?

Any help is greatly appreciated. I'm no stranger to linux, but MAC spoofing is completely new to me.

Thanks in advance!