Results 1 to 2 of 2

Thread: Radeon HD 2400 Pro and startX

  1. #1
    Just burned his ISO
    Join Date
    Apr 2009

    Default Radeon HD 2400 Pro and startX


    I am very new to Backtrack and linux, but having alot of fun learning both. I have a weird glitch when using my agp radeon hd 2400 pro however. When I do startx it tries to start, screen goes black and then most of the time I get a very small warped area of my screen with vertical white lines. Everything else is black. There is no error messages displayed.

    Figured out the ctrl-alt-f1 keystroke to get me back into the konsole after experiementing around. ran Xorg -configure, then tried startx again and worked perfect.

    Next time I booted into Backtrack 4 beta I did Xorg -configure first then startx but had same black screen again. This time I noticed that the white vertical lines in a very small portion in the center of my screen stopped and a new weird white vertical lines in some symbol shape was up. After some experimenting, I noticed that I would get a small white distorted block as a mouse cursor in the area of the shape when moving my mouse around when it was in that portion of the screen. I right clicked and sure enough a menu system came up. The menu was distorted and fuzzy and unreadable and very small as well. after clicking on some I was dropped back to the konsole. when trying startx again it worked perfect and I figured out I did a log out on the menu.

    Next few times are all the same results, but sometimes the area fo the screen keeps diminishing or even sometimes remains completely black. Its like it condenses the screen into a very small square in the middle of my monitor, and makes it completely static. Most of the time now I just ctrl-alt-f1 out and do startx again and works the second time.

    I am assuming it is a problem with the settings for the size, depth or something, though not sure why it fixes itself at random. 2 times out of all the attempts it booted up fine the first time. Also, a few times I restart it 10+ times and it never works, and only works again after a hard reboot. Most of the time it works on the 2nd attempt.

    One more thing to add, is the back of the agp card only has the lcd type connections, the many small square ones and the plus sign on left all within a rectangle shape conenction. My monitor is still a regular big one, and am using an adapter to connect to one of the slots, this also might contribute to the problem.

    If anyone has suggestions on my end if I am doing somethign wrong please inform me. If it is a bug, then wanted it to at least be known.


  2. #2
    Good friend of the forums
    Join Date
    Feb 2009


    what version of BT are you using? Have you checked online for xorg.conf configuration for your specific Radeon card by model? Try that, and get back to us with your results.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts