Hi. I finally managed to get vmware server v 1 running from Bt4.I will try to simplify how my setup is. I have installed compiz and have done alot of apt-get installs. i will address major problems you might face and how to go round them.

Ok. Steps.
1. Untar your vmware server distribution , then run vmware-install.pl

2.Run defaults in the script till you reach part which says "Before running VMware Server for the first time, you need to configure" .... here type no

3.Download the vmware -update from this location. This is not the normal vmware-any-any
update that we normally use. The link to download the vmupdate is http://www.insecure.ws/warehouse/vmw...5.5.7-2.tar.gz

4. run the runme script. When it asks you for the location of the header files matching your kernel, use path as /usr/src/linux-source-

5. Continue and everything should continue ok till end. Enter licence and start vmware.

Problems found on my setup and how i resolved them

On running vmware , it first died unexpectedly giving me these errors.

root@bt:~/Desktop/wgets/vmware-update-2.6.27-5.5.7-2# vmware
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)
/usr/lib/vmware/bin/vmware: symbol lookup error: /usr/lib/libgio-2.0.so.0: undefined symbol: g_thread_gettime

I had installed compiz earlier and i think it had broken my dbus configuration. I didnt want to remove it.I did a lot of research on the issue and tried all solutions provided. i will link all the help pages you can use to try but what finaly worked for me was to download a patch from" http://www.monarialx.it/en/vmwareserver "the patch i used was the one for vmware console version 1.0.8_2.

I downloaded the patch , run it and vualla, vmware was up and running. This worked for me. These links i have provided below should also help you out if you get the earlier error.
Since they are quite straight forward solutions on the links , i suggest that the patch be as a last option.Some solutions include apt-get remove libdbus-1.2


Will appreciate feedback if any other method works for you. Thanks to muts and to all the good people @forums.remote-exploit