Results 1 to 5 of 5

Thread: wireless Internet Sharing on laptop

  1. #1
    Just burned his ISO aurora79's Avatar
    Join Date
    Mar 2009

    Exclamation wireless Internet Sharing on laptop

    Hi, I searched many thing about this issue but could not find clear answer..

    The scenario is

    One laptop with two wireless card.

    Wlan0 = B43
    Wlan1 = RT73USB

    I want to configure one of my interface as AP mode for sharing, which one is getting internet from the other one.

    Can you help me about it?

  2. #2


    you could use airbase to start a rogue ap on one of the cards. on the other you connect to that rogue ap. if u have dhcp server set up properly, im pretty sure the other card will get internet.
    Until they become conscious they will never rebel, and until after they have rebelled they cannot become conscious...

  3. #3
    Just burned his ISO aurora79's Avatar
    Join Date
    Mar 2009

    Unhappy I have found the answer but....

    I have a configuration example but I think I made a mistake..

    the conf is

    ifconfig wlan0 up
    ifconfig wlan0 netmask
    iwconfig wlan0 mode ad-hoc
    iwconfig wlan0 key 0123456789
    iwconfig wlan0 enc on
    iwconfig wlan0 channel auto
    iwconfig wlan0 essid AD-HOC
    iptables -t nat -A POSTROUTING -o wlan1 -j MASQUERADE
    iptables -A FORWARD -i wlan1 -o wlan0 -m state --state ESTABLISHED,RELATED -j ACCEPT
    iptables -A FORWARD -i wlan0 -o wlan1 -j ACCEPT
    iptables -A FORWARD -j LOG
    Wlan0 called my interface for sharing
    wlan1 called getting internet form other AP or Modem.

    But it doesn't work

    PS: I configured my wlan1 with "network manager". and it is connecting internet successful.

  4. #4
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010
    Of course, if you really wanted to have some fun, go to Wal-Mart late at night and ask the greeter if they could help you find trashbags, roll of carpet, rope, quicklime, clorox and a shovel. See if they give you any strange looks. --Streaker69

  5. #5
    Just burned his ISO aurora79's Avatar
    Join Date
    Mar 2009

    Thumbs up OK.. I solved..

    I solved the scenario with adding end of conf file

    sh -c "echo 1 > /proc/sys/net/ipv4/ip_forward"
    /etc/init.d/networking stop

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts