Results 1 to 3 of 3

Thread: Starting BT4 in "Graphics Mode (VESA KDE)"

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Mar 2009

    Default Starting BT4 in "Graphics Mode (VESA KDE)"

    I have used backtrack3 on my laptop. I always had to choose "Graphics Mode (VESA KDE)" in the menu because "Graphics Mode (KDE)" never used to work, it just used to freeze on a black screen with the cursor.

    I want to try out backtrack4 beta. When it boots, there are only options to run the Console and not the Graphics Mode.

    So I start the console, enter the u/n and p/w, and then type "startx" to start the GUI. However, it does not work, it freezes showing a Blue screen with the cursor.
    I am guessing because it is starting the "Graphics Mode (KDE)" and not the "VESA KDE" mode.

    Please could somebody explain how to start the "Graphics Mode (VESA KDE)" from the console?


    EDIT: I should also mention that I am using backtrack4 from a burnt Live DVD. Also, instead of startx I tried bt4-crystal and that loaded the "BackTrack4" background and logo then froze too. This thread seems similar to my problem ( but I dont quite understand the solution. I entered "dpkg-reconfigure xserver-xorg" but then wasnt sure how to edit the "xorg.conf" file to put "vesa" on the end.
    Also, I dont know if the command "-forcevesa" is relevant to solving my problem, but I dont know how to utilise it. I tried "startsx -forcevesa" but that didnt work so is obviously wrong

  2. #2
    Just burned his ISO
    Join Date
    Aug 2009


    Run xwmconfig > select your favourite window manager > done.

    If you want to make the changes permanent, try opening the .xinitrc file in your home directory, then adding a line beginning with 'exec', followed by a space and then the path to your preferred window manager; so something like:

    exec /usr/bin/fluxbox

    This causes the startx command to automatically boot up that particular window manager every time.

    I'm not so familiar with BT4, but certainly BT3 had VESA KDE and Fluxbox; and if you can find them in BT4 then running either will solve your problem. However, as it's a Live DVD we're talking about; you'll have to figure out a way to save your settings onto your Hard Disk or Flash Drive.

  3. #3
    Just burned his ISO
    Join Date
    Aug 2009


    Hey gopalsingh,

    I noticed this thread is a decent bit old, but I figured I'd post what I did to finally get BT4 to run. I had the same problem - wouldn't load on BT4 with the choices provided. I had to run BT3 on VESA KDE mode on my PC as well.

    I ended up running "dpkg-reconfigure xserver-xorg" as requested in the thread you linked to (Can't post Link - see posts above).

    I went through that set-up, then ran "startx -forcevesa".
    Your problem may have been the command. You typed out "startsx -forcevesa". I'm unsure as to whether this was a accidental keystroke in your post, or what you actually typed when trying to run BT4. Instead of "startsx", it's "startx".

    Hope you already have this fixed though . Cheers!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts