Results 1 to 3 of 3

Thread: atheros 5007eg not working

  1. #1
    Just burned his ISO
    Join Date
    Mar 2009

    Default atheros 5007eg not working

    I have an asus laptop with a 5007eg card and I can't get peep out of it. It worked fine on bt3 albeit at a reduced reception strength than mycrosoft vesta,but bt3 was the only version of linux to configure it out the box without having to resort to using wyndows drivers. the switch on the side of the laptop operated as intended and the function-f2 method worked as well.
    Now with Bt4 nothing works (wifi) and there was no ndiswrapper to get wyndows drivers functional.
    Bt3 used the madwifi driver (I think) it worked well for aircrack and was the only version of linux I,ve seen to give accurate and useful info from iwconfig and ifconfig.
    All the ubuntu based versions of linux seem to have this problem(no functional wifi (ar5007eg) but Linux Mint comes with ndiswrapper built in and a host of wyndows drivers so I can at least get connected and sort out any problems.
    Ndiswrapper is a feeble workaround but would make a useful inclusion so the system can at least be used to connect to the web.
    The addition of a package manager simplifies things considerably but not being able to connect makes it useless.
    What has changed to cripple this functionality ?

  2. #2
    Senior Member
    Join Date
    Aug 2007


    First off you don't use ndiswrapper, that chipset is already supported with madwifi-ng, check under their svn for a special madwifi-ng that includes ar5007eg HAL.

    Now that is for the likes of bt3, for bt4b you might want to try enabling ath5k and manually loading it to see if it works.

  3. #3
    Just burned his ISO
    Join Date
    Jun 2008

    Default Does it work with madiwifi?

    I have an Aspire 7520 with an Atheros 5007EG too.

    May be Does it work with madwifi?

    Regards from Germany

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts