Hi folks

I came here for a couple of reasons, but as I only just registered, I can't post this in the appropriate area. Perhaps someone else could do so for me?

First, I'd like to report that the graphics and most of the wireless features of beta 4 seem to work on the Lenovo Thinkpad T61. I haven't tried all the wireless stuff yet (such as injection), but I can connect to my WPA access point and snoop packets, so it's at least partially functional. Booting from a USB stick is painless.

Second, I have a question. A search for lzm turned up nothing, but I apologize if this is discussed elsewhere...

I've been playing with modifying the USB stick such that it has a couple of extra packages installed. Compiz would be nice, new wallpapers splashscreens and muted sounds are necessary, and nessus is critical. The process seemed easy enough; let's take Nessus as an example.

I installed nessus to /opt on a non-persistant-changes instance (so, to the RAM). I then ran dir2lzm to put the opt back into a file I temporarily named new_opt.lzm. Oddly, this file was 200 megabytes, whereas the original was 60; I can't figure out the difference. Nessus is certainly no 140 megs.

So I put the USB sticks in my mac, made a backup copy of opt.lzm, then renamed new_opt.lzm to opt.lzm and overwrote the old. The boot worked perfectly, except... all the opt files are mounted to the root file system! Instead of /opt/nessus, I have /nessus. Yet all the other root filesystem mounts work fine - lib, etc, boot and so forth are all there and all contain the right files.

Anyone have any idea about either of those issues (size or mount point)? If I can get this right, I'll contribute back by making up a nice newbie guide and posting it to the guides section next week.