Results 1 to 2 of 2

Thread: Help installing BT3Final.ISO to 3rd partition of Mac OS X

  1. #1
    Just burned his ISO
    Join Date
    Jul 2009

    Default Help installing BT3Final.ISO to 3rd partition of Mac OS X

    Hi all !

    I have been trying for many days to get BT3 installed on my MacPro Intel desktop without success. I got BT3 to work perfectly using the VMWare image, but I want to get it loaded on its own partition due to netowrking problems working through Windows XP on a Mac.

    I have read the installation instructions for a "Triple Boot" installation on a Mac posted by P1llowT@lk in this forum and also read the detailed BT3 installation instructions by macpentester which I understand are based on the work of pureh@te. I have also read other relevant posts by pureh@te and Action discrete.

    Here are the links to P1llowT@lk's and macpentester's instructions (I cannot post the actual full link since I am a new member, so just add http at the start...):

    P1llowT@lk: "Triple boot: Install backtrack AFTER Windows is installed in OSX (no data loss)"

    macpentester: "Installing BackTrack 3 Final to an Intel Mac"

    Just to be clear, I have posted a few questions in the appropriate threads without reply for many days so I am trying again here... The following is a copy & paste of my other posting which contains the details of my installation and questions:

    I followed P1llowT@lk's "Triple Boot" instructions and also used macpentester's: "Installing BackTrack 3 Final to an Intel Mac" for the actual details of the BT3 installation, however, after several days of trying I still cannot get my BT3 partition to mount or boot

    Now I should mention a little about my Mac's hardware. I don't know if it makes a difference, but here are the details:

    MacPro 3 GHz Quad Xeon 64 bit with 2 GB RAM
    1. 250GB primary: Mac volume with OS X 5.7, Windows XP and Backtrack 3
    2. 500GB: OS X 5.0 (haven't had a chance to update it to 5.7 yet)
    3. 1TB: Carbon Copy clones of the 250GB and 500GB Mac volumes

    In other words, my 250 GB drive and the 500 GB drive contain OS X and are therefore bootable volumes, and additionally, since the "Carbon Copy" clones are exact duplicated of the 250 GB and 500 GB volumes, the are bootable as well.

    This is my output from Terminal's "diskutil list" command for the modified 250 GB HDD after repartitioning my drive using the Terminal procedure which works a lot better than trying to do it with Disk Utility:

    0: GUID_partition_scheme *232.9 Gi disk2
    1: EFI 200.0 Mi disk2s1
    2: Apple_HFS MacPro 250GB HDD 195.8 Gi disk2s2
    3: Microsoft Basic Data 5.1 Gi disk2s3 <--This is the BackTrack 3 partition
    4: Microsoft Basic Data WINDOWS XP 31.7 Gi disk2s4

    Now there's one strange thing about how my drive/volume names are showing up when I use the "diskutil list" command in Terminal... My primary (250 GB) drive number changes arbitrarily (?) after a reboot. In the above output it is showing up as /dev/disk2/, but right now (a few days since the above capture) it is showing up as /dev/disk0/ which matches the drive/volume name in the instructions. I haven't done anything to the drives, but the name changes back and forth for some reason. Also, rEFIt was working automatically on boot up for the first time yesterday, and now it does not launch on boot up (I have to hold the option ket to get it to work again, and sometimes it doesn't appear even with an Option boot). So it seems that OS X's boot management might be (?) acting strangely, and I don't know if this quirky behavior is in some way responsible for the BackTrack partition not showing up...

    A little more background on my installation attempts. I had tried to install BT3 a few times unsuccessfully earlier because (for reasons I don't understand) the BT3 Live CD iso would stop (freeze ?) during the installation and I would have to reboot from the ISO and start all over again. The freezes are happening arbitrarily (at random times) during the installation so it doesn't seem to be a CD problem, but I did finally manage to get the entire installation process completed on the partition I created with macpentester's method, and I made sure to erase the partition completely (zero out) before doing an installation. Additionally, I modified the Windows boot.ini file, but I did it by simply rebooting into OS X and opening the mounted Windows drive on the desktop and then opened the boot.ini file with OS X's TextEdit and made the changes that way. However, I did make a point of checking to see how my change worked using the shell procedure from within BackTrack using nano boot.ini after mounting the Windows partition and it showed up OK with all the 3s changed to 4s.

    This is P1llowT@lk's instructions on how to modify the boot.ini file:

    # mkdir /mnt/windows
    # mount /dev/sda4 /mnt/windows
    Go to your mounted Windows drive

    # cd /mnt/windows/
    Now edit the Windows boot.ini file so that it boots from the correct partition.

    # nano boot.ini
    --All you have to do is change all instances of "3" to "4", and then write the file. If you feel uncomfortable doing this, feel free to save a backup copy of the boot.ini by writing it as a different name, like "boot.ini1" before changing the numbers.

    So having had no luck getting the BT3 partition to mount, here are a few questions relating to P1llowT@lk's and macpentester's instructions that I used:

    1. Near the end of P1llowT@lk's Triple Boot procedure where he describes how to modify the "lilo.conf" file, he says "...merely add in an extra section at the end:" Then he provides the 3 additional lines to add. Now I had already modified my lilo.conf file as per macpentester's instructions when I was doing the actual installation of BackTrack 3, but it's not clear exactly where "at the end" of the lilo.conf file P1llowT@lk means... Should it be right AFTER the "label = Linux" line, or AFTER the last line of text that shows up in the nano lilo.conf screen that says something like "#End of file".

    Here is how my lilo.conf file is set up:

    boot = /dev/sda3
    image = /boot/vmlinuz
    root = /dev/sda3
    label = BT3

    So, do I add these 3 lines (see below) he listed right after the "label = BT3" line (e.g.: before the line that says something like "#End of lilo file" or what ?

    other = sda4
    label = Windows
    table = sda

    2. I also noticed that there was some discussion between pureh@te and carboncopy relating to the fine details of the lilo.conf file, particularly when it comes to the 2nd line (boot = /dev/sda3 vs. boot /dev/sda) Is there a space=space between boot and /dev or not ? If my BT3 partition is disk2s3, should I use "/dev/sda3" or simply "/dev/sda" ?

    3. P1llowT@lk also says "Modify the fstab and install it"... After Googling "fstab" I found out that "fstab" is a file, and I managed to find this fstab file in the same /etc/ directory as the lilo.conf file... However I have no idea how it should be modified, and what I need to do to "install" it... I need a little more detailed info here so I can make whatever changes are needed to this file.

    A few more details on what I have now. If I examine my 250 GB primary drive using OS X "Disk Utility" application I see the volume I created for BackTrack as "disk0s3" or "disk2s3" (depending on what the computer feels like doing that particular restart) in grey letters. If I try to mount the volume I get the following error message:

    Mount failed
    The disk “disk2s3” could not be mounted.
    Try running First Aid on the disk and then retry mounting.

    Lastly, when I "option" boot my Mac, I am getting all my drives/partitions showing up properly and can boot from them, and I also get the colorful Windows icon for my Win XP partition and also a grey "Windows" icon that says something like "Boot from Legacy OS". I assume that this "Legacy OS" is supposed to be my newly created BackTrack 3 installation, but if I try to boot from it, I actually get booted right back into my Windows partition again, even though I made changes to the boot.ini file which I thought was supposed to solve the triple boot problem. So I'm guessing that the "boot.ini" file is not redirecting the boot process to the BackTrack partition properly (?)...

    Hopefully one or more of the experts here can provide some clarification on this installation and some ideas on how I might try to get this to work....

    Thanks for your time !


    UPDATE: I noticed that when I Option-boot into Windows, I am getting a black DOS screen with 2 options, either boot into "Microsoft Windows XP Professional", or "optin /fastdetect". I am guessing that this is an indication that something I have done to Win XP the boot.ini file is somewhat working and trying to give me the option to boot into the Backtrack partition ?...
    Also, when I tried to install the lilo.conf file after editing it using this command "lilo -v -b /dev/sda3", this is the message I got:
    Warning: Ignoring entry 'boot' Reading boot sector from /dev/sda3
    Warning: Partition 3 on /dev/sda is not marked Active
    Fatal: creat /boot/map~: Read-only file system

    Hopefully these 2 points provide more clues as to what the cause of the glitch might be. It seems like I am very close to getting this partition to boot, so any help solving the problem would be appreciated

  2. #2
    Just burned his ISO
    Join Date
    Apr 2009


    Hey there,

    I just came across your posts. You can see my response on the original thread at:

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts