Results 1 to 3 of 3

Thread: How Can I Partition My Hard Disk By Using "fdisk" in BackTrack3?

  1. #1
    Just burned his ISO
    Join Date
    Jan 2009

    Default How Can I Partition My Hard Disk By Using "fdisk" in BackTrack3?

    I'm novice towards *nix. I installed backtrack 3 to experiment it. My PC has Windows Vista as the main OS. I used Virtual Box, which is VMWare like, to boot BT3 ISO version. My Windows Vista has
    4 partitions, partition C, D, E, F. I downloaded my BT3 into partition E. Every time i run VBox and run Start, BT3 that resides in E: gets started. Of course i did some configurations on VBox so it boots the BT3 from hard drive E: without putting any CD or USB.

    Local Disk (E drive has size of 39.00 GB. It is in NTFS format. It does not have anything else except the backtrack3 and associated VBox files that helps booting BT3 in VBox. Used space is 8.89 GB. Free space is 30.1 GB.

    NOTE: anything i do in BT3, nothing gets saved. Everything goes way ones i shutdown the virtual machine. To preserve my changes i have to rely on taking snapshots which is not an efficient solution. Therefore, i have to do some partitioning.

    Ok, after running BT3 i go to the terminal and typed several commands just to see what can i do prior partitioning.

    Firstly, i typed mount and i got the following info:

    bt ~ # mount
    aufs on / type aufs (rw)
    proc on /proc type proc (rw)
    sysfs on /sys type sysfs (rw)
    usbfs on /proc/bus/usb type usbfs (rw)
    Secondly, i typed df and got the following info:

    bt ~ # df -h
    Filesystem            Size  Used Avail Use% Mounted on
    aufs                  147M   11M  136M   8% /
    Thirdly, i typed fdisk -l and got the following info:

    bt ~ # fdisk -l
    Disk /dev/hda: 8589 MB, 8589934592 bytes
    16 heads, 63 sectors/track, 16644 cylinders
    Units = cylinders of 1008 * 512 = 516096 bytes
    Disk /dev/hda doesn't contain a valid partition table
    Fourthly, i typed fdisk /dev/hda1and i got:
    bt ~ # fdisk /dev/hda1
    Unable to open /dev/hda1
    Fifthly, i typed fdisk /dev/hda and i got the following:

    bt ~ # fdisk /dev/hda
    Device contains neither a valid DOS partition table, nor Sun, SGI or OSF disklabel
    Building a new DOS disklabel. Changes will remain in memory only,
    until you decide to write them. After that, of course, the previous
    content won't be recoverable.
    The number of cylinders for this disk is set to 16644.
    There is nothing wrong with that, but this is larger than 1024,
    and could in certain setups cause problems with:
    1) software that runs at boot time (e.g., old versions of LILO)
    2) booting and partitioning software from other OSs
       (e.g., DOS FDISK, OS/2 FDISK)
    Warning: invalid flag 0x0000 of partition table 4 will be corrected by w(rite)
    Command (m for help):
    Ok, i tried to explain clarify everything so i can get a good answer. I don't mind if the drive is in hda or hdb, etc. All i want to do is to make:

    Boot partition - 1.5 GB
    Swap partition - 1 GB
    Rest partition - whatever left GB

    The purpose of doing this is to be able to preserve changes freely. Even if install new application in BT3, i want to be there without the need of taking snapshots. Of course the changes will be saved in the rest of the root ("whatever left" GB)...

    Please note that i'm learning about linux & have good amount of resources. I need help regarding this issue, i got enough resources to read from.

    Referring to some of the output above, i see that there some things not working properly.

    I posted all info as much as i can. Can you please guide me on how to do it?

    I'm following this tutorial ... Once i partition successfully, i will be able to finish the tut steps.

    Excuse me if you find this question is so basic

  2. #2
    Just burned his ISO
    Join Date
    Mar 2009


    Deleted this post due to a mistake I made.
    My apology's.

  3. #3
    Developer balding_parrot's Avatar
    Join Date
    May 2007


    I can confirm that there was no edit to the OP

    There is an edit button as you pointed out,please use it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts