Results 1 to 6 of 6

Thread: RTL8187b problems (BT3+4)

  1. #1
    Just burned his ISO
    Join Date
    Feb 2009

    Default RTL8187b problems (BT3+4)

    first post, please be gentle ^^

    I own a Netgear wg111v3 usb adapter with rtl8187b chipset (bought it, cause i thought it was v2 :/ ). Of course it didnīt work with bt3, at least i didnīt get it to work. i tried the hirte driver, but kernel is too old, as i read here.
    Then i found a driver-module for bt3 (, but i didnīt know how to install (noob, sry ^^), so i put it into the bt3/modules folder in the iso, as said on the webpage (i used ISOEdit).
    Well, after burning, the cd wonīt boot, so i guess it should be installed on a different way. But which? Do i have to install BT3 before on HD?

    So, then i saw the BT4-Beta. And read, it supports my chipset.
    I got the VMWare image and the first time, i could use my adapter the way i want, but next day, it didnīt work anymore. Weird was and is, if i put it to monitor, this happens:

    root@bt:~# airmon-ng start wlan0

    Found 1 processes that could cause trouble.
    If airodump-ng, aireplay-ng or airtun-ng stops working after
    a short period of time, you may want to kill (some of) them!
    PID Name
    4354 knetworkmanager

    Interface Chipset Driver

    wlan0 RTL8187 rtl8187 - [phy1]

    The cursor stays behind the [phy1] and i canīt do anything after. even iwconfig freezes, cursor goes one line down and will stay there forever, nothing happens.
    Then i disconnect and connect the adapter again. Sometimes, i can get it to monitor this way. But then airodump works really slow and i can see nearly no networks, if i see one, then only for a short time and i receive nearly no beacons.
    Again, the first time, it worked flawlessly, though i got the "Found 1 processes that could cause trouble" message. Of course i tried to kill the process, no difference.

    So, dear BT-Users, any suggestions? Or a way to install the rtl8187b.lzm for Backtrack 3? I would be very glad if anyone could help me. Sorry for possibly bad english (iīm german )


  2. #2
    Senior Member
    Join Date
    Aug 2007


    with bt4b check to see if knetworkmanager has restarted if it has, you need to stop it via service mode...

    As for bt3, you need kernel.lzm + compat-wireless (and hope they work) + rtl8187b driver.

  3. #3
    Just burned his ISO
    Join Date
    Feb 2009


    hey hatake_kakashi, thanks for your reply!

    i thought, the new(?) rtl8187.lzm ( would work with the old kernel, am i wrong? as it states on the website:
    The driver package named r8187b.lzm for Bt3 final, (...) Put rtl8187b.lzm into directory BT3/modules.
    But when? After booting the CD or after a HD-install? Into the ISO (guess not^^)? Or do i really need to install new kernel and compat-wireless (? ^^ iīll google, i promise)?
    Would be nice if someone could point me into the right direction.

    To BT4b: weird thing is, i canīt even start knetworkmanager (there should be a gui, right? even if not, at least some text in the bash), nothing happens if i click it, or write into bash. shouldnīt be like this i guess.
    how to go to service mode? i looked for knetworkmanager in the kde services app, wasnīt there and i donīt think you mean that.

    Sorry, as my questions are probably noobish, i googled them, didnīt find a lot.
    But look, iīm not the only one:

    Thanks in advance

    it works now, at least most of the time. the "trick" is, i have to wait 1-2 minutes and airmon will finish. and i was always so impatient, that i closed the bash and didnīt wait, if something may come.
    Though, i donīt think, airmon should need a minute or two to get the card into monitor mode. Dunno if bug or because of my system, but at least it works now. Tested the VMWare at a friend too (rt73), much faster there, so iīd guess itīs the driver. but iīm not that much into linux i could really be sure. ^^
    But thanks for the suggestions, though it was my fault.


  4. #4
    Just burned his ISO
    Join Date
    Mar 2009


    Hi euleBLN, you have to kill that process before you put the device in rfmon. Use the grep comand to find that service (knetworkmanager), or don't iniciate knetworkmanager in start.

    Sorry bad english
    I'm Portuguese

  5. #5
    Just burned his ISO
    Join Date
    Feb 2009


    Hmm, iīll try that for sure! Thanks for the tip!
    Though i tried "kill 4354 (the PID)" , but i guess thatīs stupid again ^^ Will test tomorrow...
    my english is not better, maybe cause iīm german.

  6. #6
    Just burned his ISO
    Join Date
    Mar 2009

    Default SIEMENS GIGASET 108 with AR5523 Atheros

    Who is willing to help me. I need to know how i can use the SIEMENS GIGASET 108 with atheros ar5223 chipset on it to work with BACKTRACK 3 and use spoonwep to have code off WEP modem.
    Can somebody tell me iff can patch the driver in to the LIVECD backtrack 3?
    Is the ar5523 atheros chipset compactable with injections?

    Please help me !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts