Results 1 to 5 of 5

Thread: Broadcom

  1. #1
    Just burned his ISO
    Join Date
    Feb 2009

    Default Broadcom

    cd /etc/init.d
    ./networking start
    it only show the lo and eth0 of local network
    then i serch for the problem:
    $ dmesg | grep b43
    b43-pci-bridge 0000:06:00.0: device not available because of BAR 0 [0x0-0x3fff] collisions
    b43-pci-bridge: probe of 0000:06:00.0 failed with error -22
    $ lspci | grep Broadcom
    06:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
    i run the firmware loader script at /usr/share/b43-fwcutter and
    test again with modprobe and ./networking restart
    and it is not working.
    iwconfig and ifconfig wlan0 up and the other variants with no results.

  2. #2
    Senior Member
    Join Date
    Aug 2007


    First portion of the code shows like there's a bit of irq conflict or something to do on the hardware level.. Maybe google could yield more results.

    Have you also tried bt3?

  3. #3
    Senior Member secure_it's Avatar
    Join Date
    Feb 2010
    在這兩者之間 BackTrack是4 FwdTrack4


    first of all give us the output of lspci -nn
    I suspect this rev. 1 may be Broadcom 4312.which is not supported one.
    if the PCI ID return is PCI ID 14e4:4315 then this card won't work & you need Ndiswrapper to function it for connecting in managed mode only.

  4. #4
    Just burned his ISO
    Join Date
    Jun 2009


    I have exactly the same problem like described with the same output from dmesg, lspci

    lspci -nn returns 14e4:4311

    Does this mean this card is not supported? Are there some other workarounds than ndiswrapper?

    Thanks in advance.

  5. #5
    Just burned his ISO
    Join Date
    Oct 2009


    I've got BT4 Pre-Final, and I had that same message about b43 not available because of BAR 0. After I installed the broadcom STA (wl) package, I had no problems with connecting to the wireless networks, encrypted or otherwise. I do have to keep running wicd from a command line, and then the wicd-client from the internet menu.

    Google Broadcom STA for the driver page.

    One problem I am having, is doing anything with the wireless card, beyond simply connecting and browsing the net. If I issue mode monitor, i get the set failed error and cannot use the wireless connection without rebooting. If I use `airmon-ng start eth1`, I can't reconnect without rebooting. Using Kismet yields the same results. Just about anything I do, I can't get the interface to reconnect. I think it's not flushing the routing table, but not 100%. Anyway, just giving you a heads up. That package will work fine. Just follow the instructions on the readme.

    Any suggestions on that reconnecting issue?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts