Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: No sound? intel-HDA

  1. #11
    Very good friend of the forum drgr33n's Avatar
    Join Date
    Jan 2010
    Dark side of the moon ...



    There are lots of compatibility problems with these cards as there are sooo many variations.

    Here's how to get it working First lets find out what variation of card you have.

    aplay -l
    My output is as follows ..

    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 3: INTEL HDMI [INTEL HDMI]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    Ok now you can see what variation of card you have lets set it up ..

    See the following link for the configurations available .

    Either take a look at ..


    Or use the link below

    Linux Kernel Documentation :: sound : alsa : HD-Audio-Models.txt

    Find the available configurations for your card. For example Mine is STAC92xx so I look for my card.

    Once you have found your card, lets add the model to alsa's configuration file.

    cd over to /etc/modprobe.d and check the directory for the alsa configuration file. I've seen several variations for eg "alsa-base.conf, sound.conf,sound".

    Once you've found your config file you can add the model option .

    for eg ...

    options snd-hda-intel model=YOUR_MODEL
    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel
    and reboot.

    Still no sound ?? Try another configuration I know this cam be a pain in the bum but if you want sound keep going.

    More info here ...

    Hope this helps.

  2. #12
    Junior Member
    Join Date
    Aug 2007


    My damn vaio Notebook drives my crazy. Nothing is quiet working well with linux.
    Now I've got a problem with the suondcard and I can't get is solved.
    My notenook is a vaio fz11s and the soundcard is SigmaTel STAC9872AK and i can't get it to work.
    I searched the web and tried these options without having sucess:

    options snd-hda-intel model=auto
    options snd-hda-intel model=vaio
    options snd-hda-intel model=vaio position_fix=0
    options snd-hda-intel model=sony-assamd

    I need help, whats wrong with this card or am I to stupid.


    When I try aplay -l, I get the following output.
    It seems like ubuntu knows hardly that there's a soundcard

    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
    Subdevices: 1/1
    Subdevice #0: subdevice #0


Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts