I am trying to configure a USB thumbdrive that will dual-boot VistaPE and BT3. I have a lot of experience with computers and Windows/Dos based setups but not with *nix.

I formatted the thumbdrive FAT32 and installed VistaPE using WinBuilder - it boots fine. Then, I downloaded the BT3 USB ISO and copied the BOOT and BT3 folders to the thumbdrive. After running the BOOTINST batch file, the drive was bootable with BT3 and booted fine.

Next, I ran the grubinst_gui.exe from WinBuilder and changed the MBR back to use GRUB. I added an entry to the menu.lst in the root folder for BT3 - and have never gotten BT3 to boot completely. Here is my current menu.lst entry (the one that boots the furthest):

title BackTrack 3
root (hd0,0)
kernel /boot/vmlinuz max_loop-255 initrd=/boot/initrd.gz init=linuxrc load_ramdisk=1 prompt_ramdisk=0 ramdisk_size=6666 root=/dev/ram0 rw

I have tried lots of different options - unfortunately too many to remember, but this is the one that boots the furthest. The error I get is:

UDF-fs: No partition found (1)
(1,0)cfs2_fill_super: 561 ERROR: superblock probe failed!
VFS: Cannot open root device "ram0" or unknown-block(1,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)

It looks like the ramdisk is not loading but I don't know why or how to troubleshoot the issue. I've not been able to find anything about the ramdisk not loading properly. And, since BT3 boots if I use the BOOTINST batch file to change back to lilo, I don't think any of the files are corrupt.

Could someone point me in the right direction? If you need any more info, please let me know.