I made this iso from the tutorial in the guide section.
Booted up and tried to start my Atheros and ALFA devices. I noticed that they are no longer named, atheros: athx, wifix but instead both ALFA and atheros are wlanx.. My alfa device used to have wlanx before.

And as i said instead of wifix they are named to monx.

When i run wpa_supplicant i get this error:
bt ~ # wpa_supplicant -w -Dwext -iwlan1 -c/etc/wpa_supplicant.conf
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - Trying to associate with 00:01:38:80:a4:52 (SSID='B2_private_52' freq=2452 MHz)
Associated with 00:01:38:80:a4:52
WPA: Key negotiation completed with 00:01:38:80:a4:52 [PTK=CCMP GTK=TKIP]
CTRL-EVENT-CONNECTED - Connection to 00:01:38:80:a4:52 completed (auth) [id=0 id_str=]

Wether this is a problem or not i dont know, since get associated with the ap and i can use the connection fully. Should i ignore this? Or what is causing this error? I get it when using wpa_supplicant on both cards.

Is there any way to change my atheros card so it uses the old athx?