Results 1 to 3 of 3

Thread: VMWare Player + Bluetooth Dongle + BT3 Final (Issues)

  1. #1
    Just burned his ISO
    Join Date
    Sep 2008

    Default VMWare Player + Bluetooth Dongle + BT3 Final (Issues)

    Hey, was wondering if anyone here could help me with a problem I'm having with BlueTooth and BackTrack (in VMWare Player).

    Basically, my inspiron 6400 laptop doesn't come with BlueTooth as standard - so I'm using a Belkin BlueTooth dongle. For reference: For Windows Vista (my primary OS) I needed to install drivers which came on a CD (I checked - there were drivers for Vista, XP and some Mac ones, no linux), and it all worked with no issues.

    After the problems with BackTrack (as I'll explain below), I tried running Ubuntu 8.04 in VMWare and see how that coped - it was fine, it recognised the dongle and I got it to pair with my phone.

    When I tried with BackTrack however, terrible things happened (- In a very loose sense of the word "terrible"). I booted up BackTrack and connected my Belkin Bluetooth Adapter so VMWare could use it (so far, everything I'd done with Ubuntu). Soon as I'd done this, BT turned geriatric on me and was taking approximately 15 seconds to recognise a single keystroke in a shell. No matter how long I left it this never improved and I didn't get the impression that BT was picking up Bluetooth - the single act of connecting the dongle to VMWare made resulted in it not so much running BT as walking it. Aha, I jest.

    Anyway, does anyone know how I can sort this out? Does BT need a driver installed beforehand or do I need to prepare it in any other way prior to connecting the dongle? Here are the vitalstatistix:

    Laptop Model: Inspiron 6400
    Bluetooth Dongle: Belkin model F8T012xx1
    VMWare Player running BackTrack 3

    There's probably a lot more information you need that I haven't included, so just let me know what you need to know, public IP excepted, and I'll get the info for you.

    Cheers all.

  2. #2
    Just burned his ISO
    Join Date
    Sep 2008


    Any clues?

  3. #3
    Just burned his ISO
    Join Date
    Oct 2006

    Thumbs up Yes there is an issue . I have found solution GOOGLE

    Solved, by workaround

    just bougt one today had same issue in vmware other nux have this issue to .
    seems if you plug it in it sees the Usb BT as a Pegasus USB ethernet

    to resolve : Workaround: add "blacklist pegasus" to /etc/modprobe.d/blacklist.
    w w w . qbik . ch /usb/devices/showdev.php?id=4088

    All credits go to www . qbik . ch

    hope this solution works for u .

    and yes a post with url with under 15 posts

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts