Results 1 to 3 of 3

Thread: Airolib-ng: can't find help i'm looking for

  1. #1
    Just burned his ISO LMNOParis's Avatar
    Join Date
    Mar 2010

    Default Airolib-ng: database creation doesn't work

    i followed everything in xploitz's tutorial on creating a database using airolib-ng. it all looks like it's working the way it should, but it isn't. i'm using BT3 final which seems to have versions of aircrack, airolib, and sqlite that are needed. however, i have a password list that is about 22 megabytes that contains my correct passphrase and it does not work. it seems like when i run aircrack, it runs for literally a second and it's done. doesn't give me any info like "passphrase not in dictionary" or that it has found the passphrase. just says "quitting aircrack-ng". i have been looking through these forums a few times a day for the last few days trying to get info on this and i haven't found a thing. i am new to the forums as well, so i apologize in advance if i'm missing info or if this has been answered before.

  2. #2
    Join Date
    Sep 2008


    It would be helpful if you post the exact commands and maybe the output you have used.
    Be sensitive in choosing where you ask your question. You are likely to be ignored, or written off as a loser, if you:

    * post your question to a forum where it's off topic
    * post a very elementary question to a forum where advanced technical questions are expected, or vice-versa
    * cross-post to too many different newsgroups
    * post a personal e-mail to somebody who is neither an acquaintance of yours nor personally responsible for solving your problem

  3. #3
    Just burned his ISO LMNOParis's Avatar
    Join Date
    Mar 2010


    So, i did come up with a little more info on this. when i use a dictionary that's 6 KB it works fine. when i use a list that is 11 MB, i have an issue. both lists have one item per line, with a return starting each new line. here's what it looks like when i run into the issue:

    bt ~ # airolib-ng testdb --import essid ssidlist
    Database <testdb> does not already exist, creating it...
    Database <testdb> sucessfully created
    Reading file...
    bt ~ # airolib-ng testdb --import passwd biglist.txt
    3Reading file...
    Writing...nes read, 731595 invalid lines ignored.
    bt ~ # airolib-ng testdb --clean all
    Deleting invalid ESSIDs and passwords...
    Deleting unreferenced PMKs...
    Analysing index structure...
    Vacuum-cleaning the database. This could take a while...
    Checking database integrity...
    Query done. 2 rows affected.
    bt ~ # airolib-ng testdb --batch
    Computed 25000 PMK in 234 seconds (106 PMK/s, 225000 in buffer).
    bt ~ # airolib-ng testdb --verify all
    Checking all PMKs. This could take a while...

    bt ~ # aircrack-ng -r testdb wpatest-01.cap
    Opening wpatest-01.cap
    Read 900 packets.

    # BSSID ESSID Encryption

    1 00:22:6B:A7:C3:6B testap WPA (1 handshake)

    Choosing first network as target.

    Opening wpatest-01.cap

    Aircrack-ng 1.0 rc1 r1085

    [00:00:00] 24663 keys tested (38526.49 k/s)

    Current passphrase: Kawabata

    Master Key : 74 75 F3 D0 4E 33 D9 B9 ED 71 DB 05 CA 79 8E 45
    43 DB 57 B0 72 B3 41 C0 11 87 F0 C5 61 C7 6F AE

    Transcient Key : D5 D5 17 60 A9 D4 B4 F5 00 AE 52 A8 FB 0C 63 EA
    62 6D F6 F3 6A 94 5B FB F4 CA CA 60 C8 EB 29 0A
    0E 85 CB 64 4F A6 9A 76 89 A8 20 41 68 AB 56 FC
    23 68 80 59 34 15 47 C3 28 83 FC FB 91 D6 30 D1

    EAPOL HMAC : 37 4E F5 4A 62 40 36 F1 E7 2D DF 24 DC 82 5D 9E

    Quitting aircrack-ng...
    bt ~ #

    i did find post #17477 had the same issue, but there was no resolution. in the post it says to start with a smaller dictionary to see if it works, and i did. i do have the same issue described in that post though. anyone have any thoughts?

    maybe i should put this in a different category?

    so.... if anyone was looking to the answer to this, it was because i was quitting the batch prematurely. after going crazy trying to figure out why it was happening, i realized that it displays the results 25000 at a time and therefore the batch was not completing. i thought that since i was using a newer version than xlpoitz was in his tutorial, that i wasn't getting that essid part of the message. anyways, i resolved this one on my own.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts