Results 1 to 3 of 3

Thread: Aireplay + madwifi + MAC

  1. #1
    Just burned his ISO
    Join Date
    Apr 2007

    Default Aireplay + madwifi + MAC

    Hi ,
    I have read many threads about aireplay but I still didn't get the answer,
    I'm using BT1 , and my Atheros card works fine with packet injection.
    Deauth works fine.
    and I'm using a third computer with a real wifi sniffer to verify all the transmissions.

    I have tried many forms of interactive cracking but none of them increased the IVs count.

    I'm using associated clients and sometimes I associate my MAC and use my MAC instead the client's MAC.

    I suspect that the problem is with the mad-wifi driver and it's MAC.
    I change my MAC to the associated client's MAC , before I use arpreplay with --arpreplay option.
    I using 'macchanger' to change it , but then , when I check my MAC address with 'ifconfig' I get to long MAC address following by zeros.

    so whats the story with the MAC adress and mad-wifi driver..?
    what I have missed?

  2. #2
    Join Date
    Apr 2007


    Well since its BT1 you have some older mad-wifi drivers which means you must have older hardware. If this is new hardware try updating your mad-wifi drivers or just upgrade to BT3!
    This is a hackers forum :P
    root ~# aircrack-ng pwnd-01.cap
    Lenovo Thinkpad R500, OS: Ubuntu 8.10, BackTrack3, Windows XP (VirtualBox), Windows Vista, Windows 7 beta

  3. #3


    Not exactly sure of all the potential problems since it has been a long time since I used BT1 and older madwifi drivers.
    But for the macchanger problem: there is a bug in madwifi and how mac addresses are assigned. You need to destroy all VAP's, change the mac address of wifi0 and then create a new VAP using the --uniquebssid option to get the same mac address. At least, this was what happened with BT2 and BT3. YMMV.

    Best advice...upgrade to's free!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts