Results 1 to 2 of 2

Thread: Help with Broadcom 4315, didnt wanna wait :p

  1. #1
    Just burned his ISO
    Join Date
    Dec 2008

    Default Bcm4315

    Hello all! Iv been snooping around these forums for quite a bit now, after downloading BT2, and then BT3, though I never really got either of them working xD. I have searched far and wide for the answer to my first problem. My second problem isnt as urgent, but it would be nice if it were to be answered. I do not wish to be redirected to the search button or the wonderful tool of google, since I would not ahve posted this if I recieved help from them already. So..without further adieu,

    Background: I recently (within the last 3 months) bought the TX2500 (at a wonderful price of 800. I highly recommend this beautiful, small, lightweight laptop, except that it is vista..which renders the 3gb ram kinda useless, but still, beautiful laptop). For those who have encountered a problem running BT on the TX2500 because of the thermal problem, (I spent such a long time trying to find a solution...) the solution is a BIOS update! I was running on their BIOS version 6 and updated to version 9, and it works like a charm! (Look on HP website for the download)

    Problem: Short and simple, (not really...) can be divided into a few subcatagories...

    a. I am forced to run in VESA mode, and not in the normal xstart (first option) one. I dont know if this presents any problems, but I think this problem exists because of something to do with resolution? "no screens found".

    b. I cannot, no matter how hard I try, connect to the internet. I have found that SOMETHING dosent support BCM4315 (some driver?) for linux, but is there some sort of work around or do I need a new card? If so, is it one of those express cards? I have tried ifconfig, iwconfig, but there seems to be no interface output. When I try to connect with wireless manager, it says wireless interface not supported. Is BCM4315 a good choice in cards? Can it do all the basics such as injecting, monitoring, etc?

    c. I read a few guides, I dont understand whats going wrong...This is about the usb live install. So I downloaded the USB live iso, extracted with winrar, leading to an output of 2 folders. I placed both folders in a newly formatted, Sandisk Cruzer 8gb (U3 Removed) usb. I plug it in, set boot to "Boot from USB", it just ignores it, as if there were no boot files in the usb, and boots back to vista. My goal in this live usb install is that I can plug this usb into ANY computer, and it will start backtrack. I also do not wish to mess up my MBR on my TX2500 (did it twice already, it was NOT fun...)

    d. Any idea on how to get tx2500 functions to work in bt? (touchscreen, sound buttons, swivel...)

    e. If I can get touchscreen working, anyone have any idea on how to do that...forgot what it was called...something fusion..where the moniter displays a 3d cube OS, and you can push the sides of the cube to switch panels....I havnt really searched this up, xD

    Thank you for dealing with this long post. Any help is appreciated, thank you. If this is in the wrong forum, I am sorry.

    I wanna buy another Tx2500..too bad I dont have money...god, its so fking beautiful, OMFG OMFG OMFG lol..k...

  2. #2
    Senior Member
    Join Date
    Aug 2007


    a) did you try xconf? its probably an unsupported chipset. If that does not work try fixvesa. If that also fails, paste lspci output.

    b) you will need broadcom's sta driver, google for it. As for monitoring/injection capabilities. You can forget all that because broadcom's sta driver is as good as ndiswrapper in terms of any wireless auditing.

    You can either forget the whole wireless thing, or get the wireless card swapped for one that is fairly well supported. Atheros and Intel has both linux support for minipcie but atheros may serve you better in the long run, their n-phys series such as ar9xxx series or aka ath9k has linux driver support. If you don't like any of those options, the last choice is to be a guinea pig for b43 developers to hopefully develop a native driver which can and will allow you to do what you want.

    c) There was a file you have to execute which allows the disk to be booted, have you tried that?

    d) most of those functionalities depends on the driver, your best bet is to google search because you have provided little to no information about the chipsets contained.

    e) compiz fusion. That requires a functional and native linux driver. This goes back to a) which means you will need to dig up the drivers and to fix it. In worst case scenarios, you may not be able to get the 3D going if the video chip is too new. Also you may need to compile the propriatory drivers from source.

    n.b.: If your goal is to plug this dongle into any computer and expect it to work, expect lots of possible new driver installations/configurations as such. Then again, it'll probably be a good linux experience for you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts