Results 1 to 4 of 4

Thread: Neither the sysfs interface links nor the iw command

  1. #1
    Just burned his ISO
    Join Date
    Dec 2008

    Default Neither the sysfs interface links nor the iw command

    I've loaded up backtrack 3 on my Gateway laptop.
    Intel 4965 -- iwl4965 driver

    Once I stop the driver, change the mac address, then try to start it, I get this error

    ERROR: Neither the sysfs interface links nor the iw command is available.

    I've searched for forums and found most answers for iwl3945 but not iwl4965. Although I DID try to solution for 3945 to no avail. I've uninstalled the iwl4965 driver through spoonDRV as well as modprobe -r iwl4965, Try installed the raw driver, but that didn't work either. I tried to go ahead even with this error, although once I get to the ARP, I get no ARP's, even when I connect another computer to my router and download a large GB file through wireless. Here's a little bit of data from my session.

    wlan0 IEEE 802.11g ESSID:"" Nickname:""
    Mode:Monitor Freq:2.412

    bt ~ # modprobe -r iwl4965
    bt~ # iwconfig
    lo no wireless extensions.
    eth0 no wireless extensions.

    bt~ # modprobe ipwraw
    bt~ # iwconfig
    lo no wireless extensions
    eth0 no wireless extensions

    --- Loading the ipwraw didn't seem to load the driver.
    Any suggestions. Is my wireless card supported or should I be buying a new card for this laptop to do this? Let me know anything else to try. Thanks!

  2. #2
    Just burned his ISO
    Join Date
    Dec 2008


    Ok, so I put the card in monitor mode. iwconfig wlan0 mode monitor

    Didn't change the mac address, instead just went ahead with detecting. This went fine until I got to the part of collecting ARP's. I could not get any ARP's. Even with downloading a large GB file with another computer over wireless, and leaving it run for a few hours. Any suggestions?

  3. #3

  4. #4
    Just burned his ISO
    Join Date
    Jul 2009


    I know this is a bit of an old thread, but I am getting the same error here. this is what i get after i type in the command airmon-ng start wlan0

    Interface Chipset Driver

    wlan0 Intel 3945 a/b/g iwl3945 - [phy0]

    Error: Neither the sysfs interface links nor the iw command is available
    Please download and install iw from |-|ttp://

    So, I go there on my other computer and download the file, extract the .RAR file, copy the files to my flash drive, then insert my flash drive to the laptop and then I don't attempt to run the airmon-ng start wlan0 command but still i get the same thing.

    Yes, I'm a Linux nub :redface:.

    I'm not quite sure what to do with these files. Am I supposed to extract the BT3 files from the ISO, place these files I downloaded into a particular directory, then recreate the ISO, burn the ISO, and then try again? Or is there another way? Or does that error I get tell me that i'm just SOL on this working and I need to get a USB WiFi adapter or something?

    This laptop is a Gateway P-6822: Intel c2d @ 1.5Ghz CPU, Intel 3945 A/B/G WLAN

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts