First of all I want to make it clear that i'm no Linux wizard. Bt is my first real encounter with linux so go easy on me. Allso, feel free to correct my terminology because I tend to use names for things that actually are called something else. Now thats said. To the point.

First of all my trying to install bt3 on a usb stick. And finally, when I get to know it a little bit better, install it on my Aa1.
I've got one Sandisk Cruzer(4gb), and a a Kingston somethingsomething(2gb). First I tried with the Sandisk.

I downloaded the bt3final_usb.iso image and extracted the folders onto the freshly formated usb device. Then ran the bootinst.bat file. Seemed to work fine. When I try booting the aa1 with the cruzer disk I get following message:

SYSLINUX 3.36 2007-02-10 EBIOS Copyright (C) 1994-2007 H. Peter Anvin
Could not find kernel image: linux
boot: _

So I went back to the iso file and did the same thing with the Kingston. Worked fine until I boot up the aa1. First time it froze up on the bios load. Second time I got the same message as with the Sandisk.

Now. What to do?