Results 1 to 4 of 4

Thread: RT73 Connection Problems

  1. #1
    Just burned his ISO
    Join Date
    Sep 2008

    Default RT73 Connection Problems

    I'm having problems connecting via my rt73 USB card. Its an edimax 7318usg.
    I've followed the excellent article by ottovoncat. And have been digging around a bit myself so I've tried installing various drivers, including the serialmonkey latest, the old version and the 3.0.2 version from

    The problem I'm having is that I can only establish a connection on a small percentage of attempts either with wireless assistant, or via console. Whereas windows will get straight to it EVERY time. I have to remove the card and dhcpcd it a few times I might get the connection after a few attempts with BT. Its the same with bt3beta and final. Oh and I'm using virtual machine.

    Any ideas whats going on here?


  2. #2
    Senior Member
    Join Date
    Aug 2007


    Assuming that you did not do any adjustment with the antenna orientation or computer orientation, etc. I think the cause maybe a power/signal issue.

    First have you checked whether or not you have set a country code in the .dat file? most chipsets have a setting which allows one to set to a country code suitable to where they live primarily because of radio communication restrictions.

    Second is that have you tried to use other antennas, maybe more powerful ones or even directional ones?

    Last but not least. I hear version 3.x from ASPj is from a new branch off serial monkey.. you may want to try the last of the 2.x versions.

  3. #3
    Junior Member tek911's Avatar
    Join Date
    Jan 2010


    Just to offer a little credibility to this issue (yeah, ok, so i said little...) I've experienced the same thing with my rt73 Hawking USB wireless dongle. Its been an annoyance so far, but it would be nice to have the reliability there. Its annoying to know you have proper credentials to your own wap and cant connect. Hell, even open waps i've seen take multiple connection attempts prior to connection.

  4. #4
    Member Israel213's Avatar
    Join Date
    Apr 2008


    I have that same card and I didn't have to do any of that to make it work. Just do this:

    ifconfig rausb0 up
    iwlist scan
    Yours may show up on a different interface than rausb0. Sometimes when I run "iwlist scan" nothing comes up. But if I eject the card and put it back in it always works if something is in range. Hope that helps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts