Results 1 to 2 of 2

Thread: sniffing, ettercap, https, ssl

  1. #1
    Junior Member
    Join Date
    Sep 2008

    Default sniffing, ettercap, https, ssl

    hey all,

    i seem to be taking one step forward and two steps back

    first time i used ettercap, these two things worked seperatly (sniff hotmail password, remote browser), now ive got nothing.

    im using ettercap to audit my network. ive changed the etter.conf file and uncommented the the ip lines, changed the remote browser line.

    then for some reason, i logged in the next day and remote browser worked, hotmail connection timed out

    then, got hotmail to log in by typing echo 1 . /proc/sys/net/ipv4/ip_forward but it wouldnt sniff the password....however remote browser worked

    then, remote browser stopped working (even tho i could see ettercap sending command to firefox) and hotmail wasnt sniffing

    heres what ive been doing.....

    connect to network with kwlan assistant
    open ettercap -G
    select interface
    arp (tested with and without the 'remote sniffing' box checked)
    start sniffing
    like i said, hotmail was timing out so im typing 'cat /proc/sys/ipv4/ip_forward' is value is zero, im typing echo 1 > /proc etc etc

    im thining of just reinstalling backtrack 3 and starting a fresh

    if i do the following, will hotmail sniff work and will remote browser work????

    boot fresh backtrack 3

    edit etter.conf by uncommenting relevant lines, changing remote browser line to 'firefox remote -openurl= %url%host', and then go to connect to network, ettercap -G, interface, scan, arp, sniff.

    many thx

  2. #2
    Just burned his ISO
    Join Date
    Oct 2009


    Hi folks,

    are there any news on this? I'm having the same issue regarding SSL sniffing and the error: iptables v1.4.0: can't initialize iptables table `nat': Permission denied (you must be root)
    Perhaps iptables or your kernel needs to be upgraded.

    BTW I'm running Backtrack 4 VMWare Image - maybe there were any changes to the version 4 that I missed somehow.

    I've already done all steps (uncommenting the lines in the etter.conf, etc....) and I'm running ettercap as root.

    I would appreciate a hint or maybe a solution for this issue.

    Thank you guys anyway for everything - u're doing a great job!

    Best regards,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts