Results 1 to 4 of 4

Thread: DHCPD config help

  1. #1
    Join Date
    Sep 2008

    Default DHCPD config help

    So Im trying to load a dhcpd.conf file using the command:
    "dhcpd -cf /etc/dhcpd.conf at0"

    I receive the following error:
    "wrote 0 leases to lease file"
    "error openeing '/proc/net/if_net6' to list IPv6 interfaces; No such file or directory"
    "Can't list interfaces."

    I am currently using ISC's DHCP Server 4.0.0 (most recent stable release) at0 is the interface spawned by airbase-ng when I make a fake AP.

    I ran into a similar problem where it said it couldn't open the "/var/dhcpd.leases" file and I fixed it by simply creating a file with that name. However when I try to create a file for "/proc/net/if_net6" it says I cannot write to that folder. Even if I use "kdesu konqueror"

    Any help with this is much appreciated.

  2. #2
    Senior Member Thorn's Avatar
    Join Date
    Jan 2010
    The Green Dome


    You can't create and use /proc/net files in the same way as you did for the /var/dhcp.leases because anything in /proc/net is a virtural system file. More about /proc can be found here:

    From the error, it looks like you're trying to load an IP6 address, as opposed to the standard IP4. I'd double check the dhcp.conf file to make sure you loading what you really want. If you do want an IP6 address, you probably need to double-check the documentation to see how IP6 should be implemented under the dhcp.conf file.
    Stop the TSA now! Boycott the airlines.

  3. #3
    Join Date
    Sep 2008


    Thanks for the info Thorn, it is very much appreciated as always.

    I should have included my dhcpd.conf file in the first place. Anyhow here is is:

    option domain-name-servers;

    default-lease-time 60;
    max-lease-time 72;

    ddns-update-style none;


    log-facility local7;

    subnet netmask {
    option routers;
    option domain-name-servers;

    Im still trying to follow the tutorial here:

    Ive gotten everything else configured properly and linking Metasploit to my dhcp server would seem to be the final piece to this puzzle. How can I tell if an address is ipv6 vs ipv4? Is it possible to replace the offending ipv6 address with a standard ipv4? If not then how can I get my dhcp server to make this file?

  4. #4
    Join Date
    Sep 2008


    Well I googled the exact error msg and am embarassed to say that the solution was found on the boards a while ago.

    Quote Originally Posted by hhmatt81 View Post
    I just thought I would update the situation here.
    DHCPD was looking for ipv6 which is not enabled by bt3. What I had to do was go to the website and find the changelog to figure out when dhcpd first started ipv6 in thier program and get the previous version. Basically if you want to run dhcpd on bt3 you will want the last 3.x version. I downloaded 3.1.1b1 and it worked just fine. If anyone is interested as to how you get it to work I can post on how I had accomplished this. It should most likely be the same in bt2 and bt3. I don't understand why dhcpd 4.0 and above will not accept the "dhcpd -4" command since the man pages state that the -4 switch uses ipv4 only. Hopefully they get this right in later versions!
    This was tested on a wired and wireless interface. The wireless uses madwifi drivers but I doubt it matters too much as long as you can get your card into master mode.

    Much thanks to hhmatt81

    Any idea if there will be IPv6 support in furture BT realeases?
    Morpheus: "You take the blue pill - the story ends, you wake up in your bed and believe whatever you want to believe. You take the red pill - you stay in Wonderland and I show you how deep the rabbit-hole goes."

    Neo: "What if I take both?"

    Morpheus: "Don't do that! You end up like Nick Nolte!"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts