EDIT: After some more work I got it working. Mods, feel free to delete this thread since it has no relevancy.

Hi all, I am currently working on making a boot disk to boot BT3 from a USB drive on my laptop that does not support USB booting and also allow the USB drive to boot itself. My boot disk is based off of the slax-boot-from-usb. I have also modified the BT3 initrd file to accept a different folder name so that both the boot disk initrd and the BT3 initrd can use the same files since the boot disk is trying to find slax files.
Anywho, I am running into a big issue with saving the changes to BT3. My boot disk uses kernel and BT3 uses The changes with the boot disk are stored in "changes=/slax/" and with BT3 they are stored in "changes=/changes/slaxsave.dat" Whenever I try to change the syslinux.cfg in either the boot disk or on the USB drive I get an error saying "changes not writeable, using memory instead." I have tried every solution I can think of. So far, nothing has worked. If anyone knows how to make BT3 accept a directory as the changes location instead of aa slaxsave.dat file or how to make the slax-boot-from-usb accept a slaxsave.dat file that would be awesome. Thanks.